diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-09-16 13:34:20 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:20 -0300 |
commit | cac365c7228f76e68ec5be239b0746b31a1b6ec0 (patch) | |
tree | f041087c8ab8c8836cb66364e257e933df2c5555 | |
parent | 9efd256f41a93110a69cb93c1709e900496b71ac (diff) | |
download | meta-freescale-cac365c7228f76e68ec5be239b0746b31a1b6ec0.tar.gz |
openssl-qoriq: Fix runtime providers so 'openssl' is not taken as provider
Fix the following parse error:
ERROR: Multiple .bb files are due to be built which each provide openssl
(.../meta-freescale/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb
/poky/meta/recipes-connectivity/openssl/openssl_1.0.2d.bb). This usually
means one provides something the other doesn't and should.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-connectivity/openssl/openssl-qoriq.inc | 12 | ||||
-rw-r--r-- | recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb | 2 |
2 files changed, 11 insertions, 3 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq.inc b/recipes-connectivity/openssl/openssl-qoriq.inc index ee02fb79..bcbf36f2 100644 --- a/recipes-connectivity/openssl/openssl-qoriq.inc +++ b/recipes-connectivity/openssl/openssl-qoriq.inc | |||
@@ -8,6 +8,17 @@ SECTION = "libs/network" | |||
8 | LICENSE = "openssl" | 8 | LICENSE = "openssl" |
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8" |
10 | 10 | ||
11 | PROVIDES = "openssl" | ||
12 | |||
13 | python() { | ||
14 | pkgs = d.getVar('PACKAGES', True).split() | ||
15 | for p in pkgs: | ||
16 | if 'openssl-qoriq' in p: | ||
17 | d.appendVar("RPROVIDES_%s" % p, p.replace('openssl-qoriq', 'openssl')) | ||
18 | d.appendVar("RCONFLICTS_%s" % p, p.replace('openssl-qoriq', 'openssl')) | ||
19 | d.appendVar("RREPLACES_%s" % p, p.replace('openssl-qoriq', 'openssl')) | ||
20 | } | ||
21 | |||
11 | DEPENDS = "perl-native-runtime" | 22 | DEPENDS = "perl-native-runtime" |
12 | 23 | ||
13 | SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \ | 24 | SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \ |
@@ -170,4 +181,3 @@ do_install () { | |||
170 | } | 181 | } |
171 | 182 | ||
172 | BBCLASSEXTEND = "native nativesdk" | 183 | BBCLASSEXTEND = "native nativesdk" |
173 | |||
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb b/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb index 16736fb9..3b9d56eb 100644 --- a/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb +++ b/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb | |||
@@ -10,8 +10,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8" | |||
10 | export DIRS = "crypto ssl apps engines" | 10 | export DIRS = "crypto ssl apps engines" |
11 | export OE_LDFLAGS="${LDFLAGS}" | 11 | export OE_LDFLAGS="${LDFLAGS}" |
12 | 12 | ||
13 | PROVIDES = "openssl" | ||
14 | |||
15 | SRC_URI += "file://configure-targets.patch \ | 13 | SRC_URI += "file://configure-targets.patch \ |
16 | file://shared-libs.patch \ | 14 | file://shared-libs.patch \ |
17 | file://oe-ldflags.patch \ | 15 | file://oe-ldflags.patch \ |