diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2017-07-10 12:04:58 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-07-13 14:13:33 -0300 |
commit | b5c351ee708053fbc3f29d3b54c011f63d6a5319 (patch) | |
tree | 2e2b5b26e6cd51511af8ae4ba361cb5c1d0baca7 | |
parent | c3a6be93645711d4a60267c7911b8676ecbef6e3 (diff) | |
download | meta-freescale-b5c351ee708053fbc3f29d3b54c011f63d6a5319.tar.gz |
u-boot-fslc: Upgrade to 2017.07-based release
This release provides a huge improvement regarding the support for SPL
to more boards.
We now uses this and migrated following boards:
- imx6qpsabresd -> imx6qdlsabresd
- imx6qsabresd -> imx6qdlsabresd
- imx6dlsabresd -> imx6qdlsabresd
- imx6solosabresd -> imx6qdlsabresd
- imx6qpsabreauto -> imx6qdlsabreauto
- imx6qsabreauto -> imx6qdlsabreauto
- imx6dlsabreauto -> imx6qdlsabreauto
- imx6solosabreauto -> imx6qdlsabreauto
So now, the 8 boards are covered by 2 machine files. This drastically
reduces the build time and allow for a better user experience as we
can use the same image to test different boards.
In summary an image built for imx6qdlsabresd or imx6qdlsabreauto is
capable of run on a its respective board which contains a i.MX6
QuadPlus, Quad, Dual, DualLite or Solo SoC removing the need of a
specific image for each SoC type.
On top of the official 2017.07 release, following patches are
included:
801fd44563 mx6sabreauto: Make Ethernet functional again
8ccb1970b8 wandboard: Set fdt based on board_rev and board_name
e6605743e5 mx6sabresd: Enable video interfaces in bootargs
e50a2475d4 mx6sabresd: Use LDO dtb file until LDO bypass support is added
b1a4715311 mx6slevk: Use LDO dtb file until LDO bypass support is added
957409876b imx: cx9020: try pxe boot, if no vmlinuz on mmc
3608315bf1 imx: cx9020: use fdt_addr_r and ramdisk_addr_r
9a1c960516 mx6sabreauto: Add Falcon mode support
3a279e5fe8 warp: Use PARTUUID to specify the rootfs location
0f9a6703e7 embestmx6boards: Use PARTUUID to specify the rootfs location
c877510614 mx6cuboxi: Use PARTUUID to specify the rootfs location
0ada2d6caf wandboard: Use PARTUUID to specify the rootfs location
eee442362c mx6sabre: Use PARTUUID to specify the rootfs location
80a56615fa mx6sabreauto: Do not enable WEIM by default
321339efd7 imx: reorganize IMX code as other SOCs
1567ce3edc mmc: fsl_esdhc: drop CONFIG_SYS_FSL_ESDHC_FORCE_VSELECT
40294f880d dm: mmc: fsl_esdhc: handle vqmmc supply
0378edcd02 mmc: fsl_esdhc: introduce vs18_enable for 1.8V fix I/O
3657cae890 mmc: fsl_esdhc: correct type of wp_enable
45103e1030 imx6_spl: Add u-boot-dtb.img for SPL payload
61131fa4b5 mx6sabreauto: Update to SPL only mode
07a667be9b mx6qsabreauto: Add SPL support
4506c859ee mx6cuboxi: Add support for sata
a5c5962327 mx7dsabresd: Set VLD04 output to 2.8V in PMIC initialization.
4590f11b61 mx6: soc: Move mxs_dma_init() into the mxs nand driver
10d185960e net: fec_mxc: fix PHY initialization bug with CONFIG_DM_ETH
b2d4bf303e icorem6_rqs: Rename icorem6_rqs config file
af34708e1e dt-bindings: Document the Broadcom STB wake-up timer node
3e92667cfe serial: mxc: Add debug uart support
4e2b31a5c5 serial: mxc: Code cleanup
27835dae1a serial: mxc: Move common baud gen into _mxc_serial_setbrg
1ca9fe11fd serial: mxc: Move common init into _mxc_serial_init
14ac9d06be serial: mxc: Move cr1 and cr2 write to mxc_serial_setbrg
fdd1f0debc serial: mxc: Use RFDIV in dm-code
fd008b0569 serial: mxc: Add common mxc_uart reg space
2fd7878124 imx: mx6ull: fix USB bmode for i.MX 6UL and 6ULL
5c72de6152 ot1200: enable CONFIG_IMX_THERMAL for detailed thermal information
8e38f54c56 mx6sabresd: Fix guard file symbol
3320a872b0 wandboard: Remove unnecessary delay
d5ae3ce6dd cm_fx6: Remove SPL entry from CONFIG_SYS_EXTRA_OPTIONS
1325b822da cgtqmx6eval: Remove SPL entry from CONFIG_SYS_EXTRA_OPTIONS
844365a5a0 mx6slevk_spl: Remove SPL entry from CONFIG_SYS_EXTRA_OPTIONS
ff9e6d62ed mx6sabresd: Remove SPL entry from CONFIG_SYS_EXTRA_OPTIONS
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Acked-by: Daiane Angolini <daiane.angolini@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | classes/image_types_fsl.bbclass | 4 | ||||
-rw-r--r-- | conf/machine/imx6dlsabreauto.conf | 19 | ||||
-rw-r--r-- | conf/machine/imx6dlsabresd.conf | 19 | ||||
-rw-r--r-- | conf/machine/imx6qdlsabreauto.conf | 39 | ||||
-rw-r--r-- | conf/machine/imx6qdlsabresd.conf | 39 | ||||
-rw-r--r-- | conf/machine/imx6qpsabreauto.conf | 24 | ||||
-rw-r--r-- | conf/machine/imx6qpsabresd.conf | 20 | ||||
-rw-r--r-- | conf/machine/imx6qsabreauto.conf | 20 | ||||
-rw-r--r-- | conf/machine/imx6qsabresd.conf | 17 | ||||
-rw-r--r-- | conf/machine/imx6solosabreauto.conf | 21 | ||||
-rw-r--r-- | conf/machine/imx6solosabresd.conf | 19 | ||||
-rw-r--r-- | conf/machine/imx6sxsabreauto.conf | 9 | ||||
-rw-r--r-- | conf/machine/imx6sxsabresd.conf | 9 | ||||
-rw-r--r-- | conf/machine/include/imx-base.inc | 2 | ||||
-rw-r--r-- | conf/machine/include/imx6sabreauto-common.inc | 10 | ||||
-rw-r--r-- | conf/machine/include/imx6sabresd-common.inc | 10 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb) | 6 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2017.03.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2017.07.bb | 6 |
19 files changed, 106 insertions, 193 deletions
diff --git a/classes/image_types_fsl.bbclass b/classes/image_types_fsl.bbclass index e1970b2a..3010082f 100644 --- a/classes/image_types_fsl.bbclass +++ b/classes/image_types_fsl.bbclass | |||
@@ -329,11 +329,11 @@ IMAGE_CMD_sdcard () { | |||
329 | 329 | ||
330 | # The sdcard requires the rootfs filesystem to be built before using | 330 | # The sdcard requires the rootfs filesystem to be built before using |
331 | # it so we must make this dependency explicit. | 331 | # it so we must make this dependency explicit. |
332 | IMAGE_TYPEDEP_sdcard += "${@d.getVar('SDCARD_ROOTFS', 1).split('.')[-1]}" | 332 | IMAGE_TYPEDEP_sdcard_append = " ${@d.getVar('SDCARD_ROOTFS', 1).split('.')[-1]}" |
333 | 333 | ||
334 | # In case we are building for i.MX23 or i.MX28 we need to have the | 334 | # In case we are building for i.MX23 or i.MX28 we need to have the |
335 | # image stream built before the sdcard generation | 335 | # image stream built before the sdcard generation |
336 | IMAGE_TYPEDEP_sdcard += " \ | 336 | IMAGE_TYPEDEP_sdcard_append = " \ |
337 | ${@bb.utils.contains('IMAGE_FSTYPES', 'uboot-mxsboot-sdcard', 'uboot-mxsboot-sdcard', '', d)} \ | 337 | ${@bb.utils.contains('IMAGE_FSTYPES', 'uboot-mxsboot-sdcard', 'uboot-mxsboot-sdcard', '', d)} \ |
338 | ${@bb.utils.contains('IMAGE_FSTYPES', 'barebox-mxsboot-sdcard', 'barebox-mxsboot-sdcard', '', d)} \ | 338 | ${@bb.utils.contains('IMAGE_FSTYPES', 'barebox-mxsboot-sdcard', 'barebox-mxsboot-sdcard', '', d)} \ |
339 | " | 339 | " |
diff --git a/conf/machine/imx6dlsabreauto.conf b/conf/machine/imx6dlsabreauto.conf deleted file mode 100644 index 51fb7028..00000000 --- a/conf/machine/imx6dlsabreauto.conf +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6DL SABRE Automotive | ||
3 | #@SOC: i.MX6DL | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6DL SABRE Automotive | ||
5 | #@MAINTAINER: Daiane Angolini <daiane.angolini@nxp.com> | ||
6 | |||
7 | MACHINEOVERRIDES =. "mx6:mx6dl:" | ||
8 | |||
9 | require conf/machine/include/imx6sabreauto-common.inc | ||
10 | |||
11 | KERNEL_DEVICETREE = "imx6dl-sabreauto.dtb imx6dl-sabreauto-gpmi-weim.dtb imx6dl-sabreauto-ecspi.dtb \ | ||
12 | imx6dl-sabreauto-flexcan1.dtb imx6dl-sabreauto-enetirq.dtb" | ||
13 | |||
14 | UBOOT_CONFIG ??= "sd" | ||
15 | UBOOT_CONFIG[sd] = "mx6dlsabreauto_config,sdcard" | ||
16 | UBOOT_CONFIG[eimnor] = "mx6dlsabreauto_eimnor_config" | ||
17 | UBOOT_CONFIG[nand] = "mx6dlsabreauto_nand_config,ubifs" | ||
18 | UBOOT_CONFIG[spinor] = "mx6dlsabreauto_spinor_config" | ||
19 | UBOOT_CONFIG[mfgtool] = "mx6dlsabreauto_config" | ||
diff --git a/conf/machine/imx6dlsabresd.conf b/conf/machine/imx6dlsabresd.conf deleted file mode 100644 index 27b8391c..00000000 --- a/conf/machine/imx6dlsabresd.conf +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6DL SABRE Smart Device | ||
3 | #@SOC: i.MX6DL | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6DL SABRE Smart Device | ||
5 | #@MAINTAINER: Otavio Salvador <otavio@ossystems.com.br> | ||
6 | |||
7 | MACHINEOVERRIDES =. "mx6:mx6dl:" | ||
8 | |||
9 | require conf/machine/include/imx6sabresd-common.inc | ||
10 | |||
11 | KERNEL_DEVICETREE = "imx6dl-sabresd.dtb imx6dl-sabresd-ldo.dtb imx6dl-sabresd-hdcp.dtb \ | ||
12 | imx6dl-sabresd-enetirq.dtb imx6dl-sabresd-btwifi.dtb" | ||
13 | |||
14 | UBOOT_CONFIG ??= "sd" | ||
15 | UBOOT_CONFIG[sd] = "mx6dlsabresd_config,sdcard" | ||
16 | UBOOT_CONFIG[epdc] = "mx6dlsabresd_epdc_config" | ||
17 | UBOOT_CONFIG[mfgtool] = "mx6dlsabresd_config" | ||
18 | |||
19 | MACHINE_FIRMWARE += "firmware-imx-epdc" | ||
diff --git a/conf/machine/imx6qdlsabreauto.conf b/conf/machine/imx6qdlsabreauto.conf new file mode 100644 index 00000000..8967c150 --- /dev/null +++ b/conf/machine/imx6qdlsabreauto.conf | |||
@@ -0,0 +1,39 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6QP/Q/DL SABRE Automotive | ||
3 | #@SOC: i.MX6QP/Q/DL | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6QP/Q/DL SABRE Automotive | ||
5 | #@MAINTAINER: Daiane Angolini <daiane.angolini@nxp.com> | ||
6 | # | ||
7 | # This machine replaces the following machines: | ||
8 | # * imx6qpsabreauto | ||
9 | # * imx6qsabreauto | ||
10 | # * imx6dlsabreauto | ||
11 | # * imx6solosabreauto | ||
12 | # and is able to work for all the machines. | ||
13 | |||
14 | MACHINEOVERRIDES =. "mx6:mx6q:mx6dl:" | ||
15 | |||
16 | require conf/machine/include/imx-base.inc | ||
17 | require conf/machine/include/tune-cortexa9.inc | ||
18 | |||
19 | KERNEL_DEVICETREE = " \ | ||
20 | imx6qp-sabreauto.dtb imx6qp-sabreauto-ecspi.dtb imx6qp-sabreauto-flexcan1.dtb \ | ||
21 | imx6qp-sabreauto-gpmi-weim.dtb \ | ||
22 | \ | ||
23 | imx6q-sabreauto.dtb imx6q-sabreauto-gpmi-weim.dtb imx6q-sabreauto-ecspi.dtb \ | ||
24 | imx6q-sabreauto-flexcan1.dtb imx6q-sabreauto-enetirq.dtb \ | ||
25 | \ | ||
26 | imx6dl-sabreauto.dtb imx6dl-sabreauto-gpmi-weim.dtb imx6dl-sabreauto-ecspi.dtb \ | ||
27 | imx6dl-sabreauto-flexcan1.dtb imx6dl-sabreauto-enetirq.dtb \ | ||
28 | " | ||
29 | |||
30 | UBOOT_MACHINE ?= "mx6sabreauto_defconfig" | ||
31 | UBOOT_MAKE_TARGET = "all" | ||
32 | UBOOT_SUFFIX = "img" | ||
33 | SPL_BINARY = "SPL" | ||
34 | |||
35 | SERIAL_CONSOLE = "115200 ttymxc3" | ||
36 | |||
37 | MACHINE_FIRMWARE_append_mx6 = " linux-firmware-ath6k" | ||
38 | |||
39 | MACHINE_FEATURES += " pci wifi bluetooth" | ||
diff --git a/conf/machine/imx6qdlsabresd.conf b/conf/machine/imx6qdlsabresd.conf new file mode 100644 index 00000000..92c92884 --- /dev/null +++ b/conf/machine/imx6qdlsabresd.conf | |||
@@ -0,0 +1,39 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6QP/Q/DL SABRE Smart Device | ||
3 | #@SOC: i.MX6QP/Q/DL | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6QP/Q/DL SABRE Smart Device | ||
5 | #@MAINTAINER: Otavio Salvador <otavio@ossystems.com.br> | ||
6 | # | ||
7 | # This machine replaces the following machines: | ||
8 | # * imx6qpsabresd | ||
9 | # * imx6qsabresd | ||
10 | # * imx6dlsabresd | ||
11 | # * imx6solosabresd | ||
12 | # and is able to work for all the machines. | ||
13 | |||
14 | MACHINEOVERRIDES =. "mx6:mx6q:mx6dl:" | ||
15 | |||
16 | require conf/machine/include/imx-base.inc | ||
17 | require conf/machine/include/tune-cortexa9.inc | ||
18 | |||
19 | KERNEL_DEVICETREE = " \ | ||
20 | imx6qp-sabresd.dtb imx6qp-sabresd-btwifi.dtb imx6qp-sabresd-hdcp.dtb \ | ||
21 | imx6qp-sabresd-ldo.dtb imx6qp-sabresd-ldo-pcie-cert.dtb \ | ||
22 | \ | ||
23 | imx6q-sabresd.dtb imx6q-sabresd-ldo.dtb imx6q-sabresd-hdcp.dtb \ | ||
24 | imx6q-sabresd-enetirq.dtb imx6q-sabresd-btwifi.dtb \ | ||
25 | \ | ||
26 | imx6dl-sabresd.dtb imx6dl-sabresd-ldo.dtb imx6dl-sabresd-hdcp.dtb \ | ||
27 | imx6dl-sabresd-enetirq.dtb imx6dl-sabresd-btwifi.dtb \ | ||
28 | " | ||
29 | |||
30 | UBOOT_MACHINE ?= "mx6sabresd_defconfig" | ||
31 | UBOOT_MAKE_TARGET = "all" | ||
32 | UBOOT_SUFFIX = "img" | ||
33 | SPL_BINARY = "SPL" | ||
34 | |||
35 | SERIAL_CONSOLE = "115200 ttymxc0" | ||
36 | |||
37 | MACHINE_FIRMWARE_append_mx6 = " linux-firmware-ath6k" | ||
38 | |||
39 | MACHINE_FEATURES += " pci wifi bluetooth" | ||
diff --git a/conf/machine/imx6qpsabreauto.conf b/conf/machine/imx6qpsabreauto.conf deleted file mode 100644 index 505d341c..00000000 --- a/conf/machine/imx6qpsabreauto.conf +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6Q Plus SABRE Automotive | ||
3 | #@SOC: i.MX6QP | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6QP SABRE Automotive | ||
5 | #@MAINTAINER: Lauren Post <lauren.post@nxp.com> | ||
6 | |||
7 | MACHINEOVERRIDES =. "mx6:mx6q:" | ||
8 | |||
9 | require conf/machine/include/imx6sabreauto-common.inc | ||
10 | |||
11 | KERNEL_DEVICETREE = "imx6qp-sabreauto.dtb imx6qp-sabreauto-ecspi.dtb imx6qp-sabreauto-flexcan1.dtb \ | ||
12 | imx6qp-sabreauto-gpmi-weim.dtb" | ||
13 | |||
14 | PREFERRED_PROVIDER_u-boot = "u-boot-imx" | ||
15 | PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx" | ||
16 | PREFERRED_PROVIDER_virtual/kernel = "linux-imx" | ||
17 | |||
18 | UBOOT_CONFIG ??= "sd" | ||
19 | UBOOT_CONFIG[sd] = "mx6qpsabreauto_config,sdcard" | ||
20 | UBOOT_CONFIG[eimnor] = "mx6qpsabreauto_eimnor_config" | ||
21 | UBOOT_CONFIG[nand] = "mx6qpsabreauto_nand_config,ubifs" | ||
22 | UBOOT_CONFIG[spinor] = "mx6qpsabreauto_spinor_config" | ||
23 | UBOOT_CONFIG[sata] = "mx6qpsabreauto_sata_config" | ||
24 | UBOOT_CONFIG[mfgtool] = "mx6qpsabreauto_config" | ||
diff --git a/conf/machine/imx6qpsabresd.conf b/conf/machine/imx6qpsabresd.conf deleted file mode 100644 index 369d5b7d..00000000 --- a/conf/machine/imx6qpsabresd.conf +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6Q Plus SABRE Smart Device | ||
3 | #@SOC: i.MX6QP | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6QP SABRE Smart Device | ||
5 | #@MAINTAINER: Lauren Post <lauren.post@nxp.com> | ||
6 | |||
7 | MACHINEOVERRIDES =. "mx6:mx6q:" | ||
8 | |||
9 | require conf/machine/include/imx6sabresd-common.inc | ||
10 | |||
11 | KERNEL_DEVICETREE = "imx6qp-sabresd.dtb imx6qp-sabresd-btwifi.dtb imx6qp-sabresd-hdcp.dtb \ | ||
12 | imx6qp-sabresd-ldo.dtb imx6qp-sabresd-ldo-pcie-cert.dtb" | ||
13 | |||
14 | PREFERRED_PROVIDER_u-boot = "u-boot-imx" | ||
15 | PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx" | ||
16 | |||
17 | UBOOT_CONFIG ??= "sd" | ||
18 | UBOOT_CONFIG[sd] = "mx6qpsabresd_config,sdcard" | ||
19 | UBOOT_CONFIG[sata] = "mx6qpsabresd_sata_config" | ||
20 | UBOOT_CONFIG[mfgtool] = "mx6qpsabresd_config" | ||
diff --git a/conf/machine/imx6qsabreauto.conf b/conf/machine/imx6qsabreauto.conf deleted file mode 100644 index e419c5d4..00000000 --- a/conf/machine/imx6qsabreauto.conf +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6Q SABRE Automotive | ||
3 | #@SOC: i.MX6Q | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6Q SABRE Automotive | ||
5 | #@MAINTAINER: Daiane Angolini <daiane.angolini@nxp.com> | ||
6 | |||
7 | MACHINEOVERRIDES =. "mx6:mx6q:" | ||
8 | |||
9 | require conf/machine/include/imx6sabreauto-common.inc | ||
10 | |||
11 | KERNEL_DEVICETREE = "imx6q-sabreauto.dtb imx6q-sabreauto-gpmi-weim.dtb imx6q-sabreauto-ecspi.dtb \ | ||
12 | imx6q-sabreauto-flexcan1.dtb imx6q-sabreauto-enetirq.dtb" | ||
13 | |||
14 | UBOOT_CONFIG ??= "sd" | ||
15 | UBOOT_CONFIG[sd] = "mx6qsabreauto_config,sdcard" | ||
16 | UBOOT_CONFIG[eimnor] = "mx6qsabreauto_eimnor_config" | ||
17 | UBOOT_CONFIG[nand] = "mx6qsabreauto_nand_config,ubifs" | ||
18 | UBOOT_CONFIG[spinor] = "mx6qsabreauto_spinor_config" | ||
19 | UBOOT_CONFIG[sata] = "mx6qsabreauto_sata_config" | ||
20 | UBOOT_CONFIG[mfgtool] = "mx6qsabreauto_config" | ||
diff --git a/conf/machine/imx6qsabresd.conf b/conf/machine/imx6qsabresd.conf deleted file mode 100644 index ea9119a9..00000000 --- a/conf/machine/imx6qsabresd.conf +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6Q SABRE Smart Device | ||
3 | #@SOC: i.MX6Q | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6Q SABRE Smart Device | ||
5 | #@MAINTAINER: Otavio Salvador <otavio@ossystems.com.br> | ||
6 | |||
7 | MACHINEOVERRIDES =. "mx6:mx6q:" | ||
8 | |||
9 | require conf/machine/include/imx6sabresd-common.inc | ||
10 | |||
11 | KERNEL_DEVICETREE = "imx6q-sabresd.dtb imx6q-sabresd-ldo.dtb imx6q-sabresd-hdcp.dtb \ | ||
12 | imx6q-sabresd-enetirq.dtb imx6q-sabresd-btwifi.dtb" | ||
13 | |||
14 | UBOOT_CONFIG ??= "sd" | ||
15 | UBOOT_CONFIG[sd] = "mx6qsabresd_config,sdcard" | ||
16 | UBOOT_CONFIG[sata] = "mx6qsabresd_sata_config" | ||
17 | UBOOT_CONFIG[mfgtool] = "mx6qsabresd_config" | ||
diff --git a/conf/machine/imx6solosabreauto.conf b/conf/machine/imx6solosabreauto.conf deleted file mode 100644 index 09997c33..00000000 --- a/conf/machine/imx6solosabreauto.conf +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6Solo SABRE Automotive | ||
3 | #@SOC: i.MX6S | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6Solo SABRE Automotive | ||
5 | |||
6 | MACHINEOVERRIDES =. "mx6:mx6dl:" | ||
7 | |||
8 | require conf/machine/include/imx6sabresd-common.inc | ||
9 | |||
10 | KERNEL_DEVICETREE = "imx6dl-sabreauto.dtb" | ||
11 | |||
12 | PREFERRED_PROVIDER_u-boot = "u-boot-imx" | ||
13 | PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx" | ||
14 | KERNEL_IMAGETYPE = "zImage" | ||
15 | |||
16 | UBOOT_CONFIG ??= "sd" | ||
17 | UBOOT_CONFIG[sd] = "mx6solosabreauto_config,sdcard" | ||
18 | UBOOT_CONFIG[eimnor] = "mx6solosabreauto_eimnor_config" | ||
19 | UBOOT_CONFIG[nand] = "mx6solosabreauto_nand_config,ubifs" | ||
20 | UBOOT_CONFIG[spinor] = "mx6solosabreauto_spinor_config" | ||
21 | UBOOT_CONFIG[mfgtool] = "mx6solosabreauto_config" | ||
diff --git a/conf/machine/imx6solosabresd.conf b/conf/machine/imx6solosabresd.conf deleted file mode 100644 index 65155bcc..00000000 --- a/conf/machine/imx6solosabresd.conf +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: NXP i.MX6Solo SABRE Smart Device | ||
3 | #@SOC: i.MX6S | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX6Solo SABRE Smart Device | ||
5 | #@MAINTAINER: Otavio Salvador <otavio@ossystems.com.br> | ||
6 | |||
7 | MACHINEOVERRIDES =. "mx6:mx6dl:" | ||
8 | |||
9 | require conf/machine/include/imx6sabresd-common.inc | ||
10 | |||
11 | KERNEL_DEVICETREE = "imx6dl-sabresd.dtb imx6dl-sabresd-ldo.dtb" | ||
12 | |||
13 | PREFERRED_PROVIDER_u-boot = "u-boot-imx" | ||
14 | PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx" | ||
15 | KERNEL_IMAGETYPE = "zImage" | ||
16 | |||
17 | UBOOT_CONFIG ??= "sd" | ||
18 | UBOOT_CONFIG[sd] = "mx6solosabresd_config,sdcard" | ||
19 | UBOOT_CONFIG[mfgtool] = "mx6solosabresd_config" | ||
diff --git a/conf/machine/imx6sxsabreauto.conf b/conf/machine/imx6sxsabreauto.conf index b3bae2a4..19a8d9f8 100644 --- a/conf/machine/imx6sxsabreauto.conf +++ b/conf/machine/imx6sxsabreauto.conf | |||
@@ -6,7 +6,8 @@ | |||
6 | 6 | ||
7 | MACHINEOVERRIDES =. "mx6:mx6sx:" | 7 | MACHINEOVERRIDES =. "mx6:mx6sx:" |
8 | 8 | ||
9 | require conf/machine/include/imx6sabreauto-common.inc | 9 | require conf/machine/include/imx-base.inc |
10 | require conf/machine/include/tune-cortexa9.inc | ||
10 | 11 | ||
11 | KERNEL_DEVICETREE = "imx6sx-sabreauto.dtb imx6sx-sabreauto-m4.dtb" | 12 | KERNEL_DEVICETREE = "imx6sx-sabreauto.dtb imx6sx-sabreauto-m4.dtb" |
12 | 13 | ||
@@ -18,3 +19,9 @@ UBOOT_CONFIG[sd] = "mx6sxsabreauto_config,sdcard" | |||
18 | UBOOT_CONFIG[qspi1] = "mx6sxsabreauto_qspi1_config" | 19 | UBOOT_CONFIG[qspi1] = "mx6sxsabreauto_qspi1_config" |
19 | UBOOT_CONFIG[nand] = "mx6sxsabreauto_nand_config,ubifs" | 20 | UBOOT_CONFIG[nand] = "mx6sxsabreauto_nand_config,ubifs" |
20 | UBOOT_CONFIG[mfgtool] = "mx6sxsabreauto_config" | 21 | UBOOT_CONFIG[mfgtool] = "mx6sxsabreauto_config" |
22 | |||
23 | SERIAL_CONSOLE = "115200 ttymxc3" | ||
24 | |||
25 | MACHINE_FIRMWARE_append_mx6 = " linux-firmware-ath6k" | ||
26 | |||
27 | MACHINE_FEATURES += " pci wifi bluetooth" | ||
diff --git a/conf/machine/imx6sxsabresd.conf b/conf/machine/imx6sxsabresd.conf index d702bed7..f7946361 100644 --- a/conf/machine/imx6sxsabresd.conf +++ b/conf/machine/imx6sxsabresd.conf | |||
@@ -6,7 +6,8 @@ | |||
6 | 6 | ||
7 | MACHINEOVERRIDES =. "mx6:mx6sx:" | 7 | MACHINEOVERRIDES =. "mx6:mx6sx:" |
8 | 8 | ||
9 | require conf/machine/include/imx6sabresd-common.inc | 9 | require conf/machine/include/imx-base.inc |
10 | require conf/machine/include/tune-cortexa9.inc | ||
10 | 11 | ||
11 | KERNEL_DEVICETREE = "imx6sx-sdb.dtb imx6sx-sdb-emmc.dtb imx6sx-sdb-m4.dtb \ | 12 | KERNEL_DEVICETREE = "imx6sx-sdb.dtb imx6sx-sdb-emmc.dtb imx6sx-sdb-m4.dtb \ |
12 | imx6sx-sdb-sai.dtb imx6sx-sdb-lcdif1.dtb imx6sx-sdb-ldo.dtb \ | 13 | imx6sx-sdb-sai.dtb imx6sx-sdb-lcdif1.dtb imx6sx-sdb-ldo.dtb \ |
@@ -19,3 +20,9 @@ UBOOT_CONFIG[emmc] = "mx6sxsabresd_emmc_config,sdcard" | |||
19 | UBOOT_CONFIG[qspi2] = "mx6sxsabresd_qspi2_config" | 20 | UBOOT_CONFIG[qspi2] = "mx6sxsabresd_qspi2_config" |
20 | UBOOT_CONFIG[m4fastup] = "mx6sxsabresd_m4fastup_config" | 21 | UBOOT_CONFIG[m4fastup] = "mx6sxsabresd_m4fastup_config" |
21 | UBOOT_CONFIG[mfgtool] = "mx6sxsabresd_config" | 22 | UBOOT_CONFIG[mfgtool] = "mx6sxsabresd_config" |
23 | |||
24 | SERIAL_CONSOLE = "115200 ttymxc0" | ||
25 | |||
26 | MACHINE_FIRMWARE_append_mx6 = " linux-firmware-ath6k" | ||
27 | |||
28 | MACHINE_FEATURES += " pci wifi bluetooth" | ||
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index 6c7e494e..6c54d232 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -93,7 +93,7 @@ MACHINE_SOCARCH_SUFFIX_use-mainline-bsp = "-imx" | |||
93 | MACHINE_ARCH_FILTER = "virtual/kernel" | 93 | MACHINE_ARCH_FILTER = "virtual/kernel" |
94 | MACHINE_SOCARCH_FILTER_append_imx = " alsa-lib" | 94 | MACHINE_SOCARCH_FILTER_append_imx = " alsa-lib" |
95 | MACHINE_SOCARCH_FILTER_append_imxvpu = " imx-vpu libimxvpuapi imx-codec imx-vpuwrap imx-parser" | 95 | MACHINE_SOCARCH_FILTER_append_imxvpu = " imx-vpu libimxvpuapi imx-codec imx-vpuwrap imx-parser" |
96 | MACHINE_SOCARCH_FILTER_append_imxgpu2d = " virtual/libopenvg virtual/libgles1 virtual/libgles2 virtual/egl virtual/mesa virtual/libgl virtual/libg2d cairo pango weston" | 96 | MACHINE_SOCARCH_FILTER_append_imxgpu2d = " virtual/libopenvg virtual/libgles1 virtual/libgles2 virtual/egl virtual/mesa virtual/libgl virtual/libg2d cairo pango weston gstreamer1.0-plugins-bad" |
97 | MACHINE_SOCARCH_FILTER_append_imxpxp = " imx-codec imx-parser" | 97 | MACHINE_SOCARCH_FILTER_append_imxpxp = " imx-codec imx-parser" |
98 | MACHINE_SOCARCH_FILTER_append_use-mainline-bsp = " \ | 98 | MACHINE_SOCARCH_FILTER_append_use-mainline-bsp = " \ |
99 | qtbase \ | 99 | qtbase \ |
diff --git a/conf/machine/include/imx6sabreauto-common.inc b/conf/machine/include/imx6sabreauto-common.inc deleted file mode 100644 index b4f37b3c..00000000 --- a/conf/machine/include/imx6sabreauto-common.inc +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | # Provides the i.MX6 SABRE AUTO common settings | ||
2 | |||
3 | require conf/machine/include/imx-base.inc | ||
4 | require conf/machine/include/tune-cortexa9.inc | ||
5 | |||
6 | SERIAL_CONSOLE = "115200 ttymxc3" | ||
7 | |||
8 | MACHINE_FIRMWARE_append_mx6 = " linux-firmware-ath6k" | ||
9 | |||
10 | MACHINE_FEATURES += " pci wifi bluetooth" | ||
diff --git a/conf/machine/include/imx6sabresd-common.inc b/conf/machine/include/imx6sabresd-common.inc deleted file mode 100644 index 40e3cde6..00000000 --- a/conf/machine/include/imx6sabresd-common.inc +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | # Provides the i.MX6 SABRE SD common settings | ||
2 | |||
3 | require conf/machine/include/imx-base.inc | ||
4 | require conf/machine/include/tune-cortexa9.inc | ||
5 | |||
6 | SERIAL_CONSOLE = "115200 ttymxc0" | ||
7 | |||
8 | MACHINE_FIRMWARE_append_mx6 = " linux-firmware-ath6k" | ||
9 | |||
10 | MACHINE_FEATURES += " pci wifi bluetooth" | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.07.bb index 86a6abf2..b6602c0f 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.09.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.07.bb | |||
@@ -5,10 +5,10 @@ SECTION = "bootloader" | |||
5 | DEPENDS = "openssl" | 5 | DEPENDS = "openssl" |
6 | PROVIDES = "u-boot-mxsboot" | 6 | PROVIDES = "u-boot-mxsboot" |
7 | 7 | ||
8 | PV = "v2016.09+git${SRCPV}" | 8 | PV = "v2017.07+git${SRCPV}" |
9 | 9 | ||
10 | SRCREV = "a3d27ead69a9e84a7794117cf965af20d0cfec4f" | 10 | SRCREV = "801fd445636a6d136ffb1a991245e183643a8934" |
11 | SRCBRANCH = "2016.09+fslc" | 11 | SRCBRANCH = "2017.07+fslc" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" | 13 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" |
14 | 14 | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2017.03.bb b/recipes-bsp/u-boot/u-boot-fslc_2017.03.bb deleted file mode 100644 index ce62e53a..00000000 --- a/recipes-bsp/u-boot/u-boot-fslc_2017.03.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | include u-boot-fslc.inc | ||
2 | |||
3 | PV = "v2017.03+git${SRCPV}" | ||
4 | |||
5 | SRCREV = "ac3b20cdbe5282fbfa46d7fd39358f5ee07e24d9" | ||
6 | SRCBRANCH = "2017.03+fslc" | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2017.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2017.07.bb new file mode 100644 index 00000000..f2cd8e5e --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-fslc_2017.07.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | include u-boot-fslc.inc | ||
2 | |||
3 | PV = "v2017.07+git${SRCPV}" | ||
4 | |||
5 | SRCREV = "801fd445636a6d136ffb1a991245e183643a8934" | ||
6 | SRCBRANCH = "2017.07+fslc" | ||