diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-10-19 08:41:01 +0000 |
---|---|---|
committer | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-10-19 08:41:01 +0000 |
commit | 16651e646acdd69a0ee2a6484b8e9b21fdb2b3a6 (patch) | |
tree | 05e10d329b79c171182ca6809f1853a1898737e3 | |
parent | 9d05232d9a12a52d17039003f8d4b23ac001d378 (diff) | |
download | meta-freescale-16651e646acdd69a0ee2a6484b8e9b21fdb2b3a6.tar.gz |
linux-fslc: update to v5.14.7
Kernel repository has been upgraded up to v5.14.7 from stable korg.
Following upstream commits are included in this version:
----
56c0ace445bd Linux 5.14.7
a7593244dc31 s390/bpf: Fix branch shortening during codegen pass
6a8787093b04 s390/bpf: Fix 64-bit subtraction of the -0x80000000 constant
7a31ec4d215a s390/bpf: Fix optimizing out zero-extensions
10203c14d608 net: dsa: bcm_sf2: Fix array overrun in bcm_sf2_num_active_ports()
45c0e1ee3e9f bnxt_en: Fix error recovery regression
47b119613dcf net: renesas: sh_eth: Fix freeing wrong tx descriptor
45f8ba56d4dd cxgb3: fix oops on module removal
dc2ebd4105b0 mfd: lpc_sch: Rename GPIOBASE to prevent build error
4666248379e9 ip6_gre: Revert "ip6_gre: add validation for csum_start"
9ae3fccac631 bnxt_en: Fix possible unintended driver initiated error recovery
05935d1da3c7 bnxt_en: Fix asic.rev in devlink dev info command
a4dc86f679b2 bnxt_en: fix stored FW_PSID version masks
c70b2b2ca0c0 net: dsa: b53: Fix IMP port setup on BCM5301x
4bf5d5224ffc ip_gre: validate csum_start only on pull
faa3bd11de91 iwlwifi: pnvm: Fix a memory leak in 'iwl_pnvm_get_from_fs()'
b5fe5a750923 iwlwifi: move get pnvm file name to a separate function
2b6c8100c693 qlcnic: Remove redundant unlock in qlcnic_pinit_from_rom
ec5150055362 fq_codel: reject silly quantum parameters
7d0458a67e6d netfilter: socket: icmp6: fix use-after-scope
864251f26753 mptcp: Only send extra TCP acks in eligible socket states
bd65986f3e2d net: dsa: b53: Set correct number of ports in the DSA struct
7c5800c3cab8 net: dsa: b53: Fix calculating number of switch ports
98641c732e95 net: hso: add failure handler for add_net_device
5d37e739f531 selftests: mptcp: clean tmp files in simult_flows
e35820fb5641 mptcp: fix possible divide by zero
122a20d062e8 tools build: Fix feature detect clean for out of source builds
e67dcd6556fa net: dsa: tag_rtl4_a: Fix egress tags
fcf7264e8714 io_uring: retry in case of short read on block device
e7009e8ecdf6 gpio: mpc8xxx: Use 'devm_gpiochip_add_data()' to simplify the code and avoid a leak
450adfabe059 gpio: mpc8xxx: Fix a potential double iounmap call in 'mpc8xxx_probe()'
8c7ba0ec7c45 gpio: mpc8xxx: Fix a resources leak in the error handling path of 'mpc8xxx_probe()'
17bf84a9e8a2 perf bench inject-buildid: Handle writen() errors
20e60bf86492 perf unwind: Do not overwrite FEATURE_CHECK_LDFLAGS-libunwind-{x86,aarch64}
82d7271c9ead perf config: Fix caching and memory leak in perf_home_perfconfig()
eb15078cd848 ARC: export clear_user_page() for modules
6989067d55cd mtd: rawnand: cafe: Fix a resource leak in the error handling path of 'cafe_nand_probe()'
08a901da171d watchdog: Fix NULL pointer dereference when releasing cdev
59aba0148404 PCI: Sync __pci_register_driver() stub for CONFIG_PCI=n
638fb35ca3e4 PCI/PTM: Remove error message at boot
b3c9eff1a853 KVM: arm64: Handle PSCI resets before userspace touches vCPU state
bd5ad57a4dc7 KVM: arm64: Fix read-side race on updates to vcpu reset state
7655140eda86 mtd: mtdconcat: Check _read, _write callbacks existence before assignment
5cd5c566aaf3 mtd: mtdconcat: Judge callback existence based on the master
a452dc09a5a6 tracing/boot: Fix a hist trigger dependency for boot time tracing
3be43a9ac4a9 mfd: tqmx86: Clear GPIO IRQ resource when no IRQ is set
1104ea6b8e2a PCI: Fix pci_dev_str_match_path() alloc while atomic bug
619b6ad1b135 KVM: arm64: Restrict IPA size to maximum 48 bits on 4K and 16K page size
39880692657c netfilter: nft_ct: protect nft_ct_pcpu_template_refcnt with mutex
408c5b7081b1 PCI: iproc: Fix BCMA probe resource handling
43f59fff1fdf PCI: of: Don't fail devm_pci_alloc_host_bridge() on missing 'ranges'
b4ae6f96d7db PCI: controller: PCI_IXP4XX should depend on ARCH_IXP4XX
86bfda3f6cb5 backlight: ktd253: Stabilize backlight
31c16809d0bc mfd: axp20x: Update AXP288 volatile ranges
eb3eeb317385 net: phylink: add suspend/resume support
54f62219145c stmmac: dwmac-loongson:Fix missing return value
a308deafe4e3 NTB: perf: Fix an error code in perf_setup_inbuf()
9c787064f0a8 NTB: Fix an error code in ntb_msit_probe()
23edad31b827 ethtool: Fix an error code in cxgb2.c
0fc65686c1de loop: reduce the loop_ctl_mutex scope
b1438181dcee PCI: ibmphp: Fix double unmap of io_mem
88013a0c5d99 block, bfq: honor already-setup queue merges
488e251c6987 net: usb: cdc_mbim: avoid altsetting toggling for Telit LN920
2bbf4c40bfb2 flow: fix object-size-mismatch warning in flowi{4,6}_to_flowi_common()
2a2ada738da6 Set fc_nlinfo in nh_create_ipv4, nh_create_ipv6
1680812a0f7d octeontx2-af: Add additional register check to rvu_poll_reg()
ed0f3b99c5a1 watchdog: Start watchdog in watchdog_set_last_hw_keepalive only if appropriate
a1d4322f6782 PCI: Add ACS quirks for Cavium multi-function devices
a87aa051d7bd PCI: j721e: Add PCIe support for AM64
1def82a63892 PCI: j721e: Add PCIe support for J7200
06ef79094f16 PCI: cadence: Add quirk flag to set minimum delay in LTSSM Detect.Quiet state
cdade20269a4 PCI: cadence: Use bitfield for *quirk_retrain_flag* instead of bool
53347ed7cc2e tracing/probes: Reject events which have the same name of existing one
86ddc7397906 KVM: arm64: Make hyp_panic() more robust when protected mode is enabled
35f2ecc7a6e5 riscv: fix the global name pfn_base confliction error
f9910fae78de PCI: rcar: Fix runtime PM imbalance in rcar_pcie_ep_probe()
24bc88f6d28e mfd: Don't use irq_create_mapping() to resolve a mapping
2edfc28e4a80 PCI: tegra: Fix OF node reference leak
119f11c0a5fd PCI: tegra194: Fix MSI-X programming
2338e1b02584 PCI: tegra194: Fix handling BME_CHGED event
cba893f7193a fuse: fix use after free in fuse_read_interrupt()
bd95a58ccd96 PCI: Add ACS quirks for NXP LX2xx0 and LX2xx2 platforms
6bd777c9cece mfd: db8500-prcmu: Adjust map to reality
28fd51c13227 remoteproc: qcom: wcnss: Fix race with iris probe
65fa28b7695f dt-bindings: mtd: gpmc: Fix the ECC bytes vs. OOB bytes equation
d49e2c649480 mlxbf_gige: clear valid_polarity upon open
0cacc8c5f8b8 net: dsa: flush switchdev workqueue before tearing down CPU/DSA ports
3e8418e36177 blkcg: fix memory leak in blk_iolatency_init
2990e56bb82c nvme: avoid race in shutdown namespace removal
0eb2133475b4 net: hns3: fix the exception when query imp info
cd0015a07cf7 net: dsa: lantiq_gswip: Add 200ms assert delay
a4604b3cde1c net: dsa: qca8k: fix kernel panic with legacy mdio mapping
d2a6d9c240e5 ice: Correctly deal with PFs that do not support RDMA
084ba1ace0b9 net/mlx5e: Fix mutual exclusion between CQE compression and HW TS
080ce6343eff Drivers: hv: vmbus: Fix kernel crash upon unbinding a device from uio_hv_generic driver
4664ad853f4b net: stmmac: platform: fix build warning when with !CONFIG_PM_SLEEP
dbf905bcd28a net: hns3: fix the timing issue of VF clearing interrupt sources
39da2bc7e5ac net: hns3: disable mac in flr process
6f3d5ea0f817 net: hns3: change affinity_mask to numa node range
ab73511cb258 net: hns3: pad the short tunnel frame before sending to hardware
acd97a2a900b bnxt_en: make bnxt_free_skbs() safe to call after bnxt_free_mem()
da15ae0968fa s390/pci_mmio: fully validate the VMA before calling follow_pte()
722ee4b29a59 powerpc/mce: Fix access error in mce handler
31f2beef3ef1 powerpc/64s: system call rfscv workaround for TM bugs
9151f0bdc3a1 KVM: PPC: Book3S HV: Tolerate treclaim. in fake-suspend mode changing registers
d5bf0fd8f4d1 ibmvnic: check failover_pending in login response
e7b260fd7309 dt-bindings: arm: Fix Toradex compatible typo
322b40b5094e udp_tunnel: Fix udp_tunnel_nic work-queue type
2a791fa9de15 qed: Handle management FW error
01d935828325 selftest: net: fix typo in altname test
88ed682408f1 tcp: fix tp->undo_retrans accounting in tcp_sacktag_one()
e50f1df204d5 x86/uaccess: Fix 32-bit __get_user_asm_u64() when CC_HAS_ASM_GOTO_OUTPUT=y
893124376b0a net: dsa: destroy the phylink instance on any error in dsa_slave_phy_setup
43867a55875e net/af_unix: fix a data-race in unix_dgram_poll
178c282e543f vhost_net: fix OoB on sendmsg() failure.
e8f84d205910 gen_compile_commands: fix missing 'sys' package
b5663238281f net: ipa: initialize all filter table slots
bb84e79f4f79 events: Reuse value read using READ_ONCE instead of re-reading it
398026b3e1fe powerpc/64s: system call scv tabort fix for corrupt irq soft-mask state
ae66447e9959 nvme-tcp: fix io_work priority inversion
48e04f88a216 igc: fix tunnel offloading
2283da2a64fb net: stmmac: fix system hang caused by eee_ctrl_timer during suspend/resume
c29323ea0eb6 net/mlx5: Fix potential sleeping in atomic context
31aec563de90 net/mlx5: FWTrace, cancel work on alloc pd error flow
bef2db97a77c perf machine: Initialize srcline string member in add_location struct
a628e6c8eaa7 drm/i915/dp: return proper DPRX link training result
80e336d29217 rtc: cmos: Disable irq around direct invocation of cmos_interrupt()
bc9299c5270f drm/rockchip: cdn-dp-core: Make cdn_dp_core_resume __maybe_unused
2926d3827105 tipc: increase timeout in tipc_sk_enqueue()
3433e7d135de r6040: Restore MDIO clock frequency after MAC reset
6e4a2519c912 net/l2tp: Fix reference count leak in l2tp_udp_recv_core
51f7b364a2d1 dccp: don't duplicate ccid when cloning dccp sock
3e811a5c96fa ptp: dp83640: don't define PAGE0
9ac80ef7cc41 net-caif: avoid user-triggerable WARN_ON(1)
1f2f637b31e5 net/{mlx5|nfp|bnxt}: Remove unnecessary RTNL lock assert
a2db1c64f2ce net: remove the unnecessary check in cipso_v4_doi_free
35ee11c8f438 ethtool: Fix rxnfc copy to user buffer overflow
ba099fe50c0a tipc: fix an use-after-free issue in tipc_recvmsg
54089df947b0 x86/mce: Avoid infinite loop for copy from user recovery
d6d35beff5d4 x86/mm: Fix kern_addr_valid() to cope with existing but not present entries
388e1fd62e8c x86/pat: Pass valid address to sanitize_phys()
6ed2d5e30cf4 net: qrtr: revert check in qrtr_endpoint_post()
2aeb3cfb82ae s390/sclp: fix Secure-IPL facility detection
3405e0d5e4a3 drm/etnaviv: add missing MMU context put when reaping MMU mapping
ac533196011b drm/etnaviv: reference MMU context when setting up hardware state
3e8cfbab6c8b drm/etnaviv: fix MMU context leak on GPU reset
4ad4e5f3f20a drm/etnaviv: exec and MMU state is lost when resetting the GPU
c80772895cc0 drm/etnaviv: keep MMU context across runtime suspend/resume
18e0930dd776 drm/etnaviv: stop abusing mmu_context as FE running marker
d73f98558f4a drm/etnaviv: put submit prev MMU context when it exists
3ea21946ba7b drm/etnaviv: return context from etnaviv_iommu_context_get
dc1fd142dcf2 drm/i915/dp: Use max params for panels < eDP 1.4
d717dcf122ea io_uring: allow retry for O_NONBLOCK if async is supported
3704a556158e drm/radeon: pass drm dev radeon_agp_head_init directly
fe232886fb71 drm/amdkfd: separate kfd_iommu_resume from kfd_resume
815cf7b38a1c drm/amd/pm: fix the issue of uploading powerplay table
413a8644966a drm/amdgpu: move iommu_resume before ip init/resume
64ca7170c9b1 drm/amdgpu: add amdgpu_amdkfd_resume_iommu
2a0dfd8e2878 drm/amdgpu: fix use after free during BO move
05e7e2d760aa drm/amdgpu: use IS_ERR for debugfs APIs
ab55e44ea8dc drm/amd/amdgpu: Increase HWIP_MAX_INSTANCE to 10
deeb5db10001 drm/amd/pm: fix runpm hang when amdgpu loaded prior to sound driver
05a19da7efcd drm/amd/display: Fix white screen page fault for gpuvm
c6d921d1e88c drm/amd/display: dsc mst 2 4K displays go dark with 2 lane HBR3
c5548625a758 drm/amd/display: Get backlight from PWM if DMCU is not initialized
73892cbd7c88 PCI: Add AMD GPU multi-function power dependencies
0b4547d3ee46 PM: base: power: don't try to use non-existing RTC for storing data
06cd58aa18f2 arm64/sve: Use correct size when reinitialising SVE state
5c687b528a92 bnx2x: Fix enabling network interfaces without VFs
6860535176f2 xen: fix usage of pmd_populate in mremap for pv guests
93ce214dc0c4 xen: reset legacy rtc flag for PV domU
90b2c99e4769 swiotlb-xen: fix late init retry
4eb05451173e swiotlb-xen: avoid double free
71e32edd2210 io_uring: ensure symmetry in handling iter types in loop_rw_iter()
1e93a76c6995 net: stmmac: fix MAC not working when system resume back with WoL active
----
Link: https://lore.kernel.org/r/20210920163921.633181900@linuxfoundation.org # v5.14.7
Link: https://github.com/Freescale/linux-fslc/pull/448
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
-rw-r--r-- | recipes-kernel/linux/linux-fslc_5.14.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-fslc_5.14.bb b/recipes-kernel/linux/linux-fslc_5.14.bb index f67c1b7b..9c721f07 100644 --- a/recipes-kernel/linux/linux-fslc_5.14.bb +++ b/recipes-kernel/linux/linux-fslc_5.14.bb | |||
@@ -19,9 +19,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | |||
19 | # | 19 | # |
20 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 20 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
21 | # should be updated once patchlevel is merged. | 21 | # should be updated once patchlevel is merged. |
22 | LINUX_VERSION = "5.14.6" | 22 | LINUX_VERSION = "5.14.7" |
23 | 23 | ||
24 | KBRANCH = "5.14.x+fslc" | 24 | KBRANCH = "5.14.x+fslc" |
25 | SRCREV = "79bcc3a5a2e73ad1024c63fd0e7c368652e48145" | 25 | SRCREV = "0bdf3f08cbc02a76b99cec3fab5069441153d7fa" |
26 | 26 | ||
27 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf|use-mainline-bsp)" | 27 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf|use-mainline-bsp)" |