summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-05-12 07:36:46 -0300
committerGitHub <noreply@github.com>2022-05-12 07:36:46 -0300
commit804916e7fd0d5fda38f3c6771fa3a8ede6784ac2 (patch)
treee152b2ea674c4fad0bf73dd87710cc59bb0af611
parentf77bf2df8331a34bcf38f39073ec920a952680aa (diff)
parent163dfbf76c881216473b32efe266c0e74a39b142 (diff)
downloadmeta-freescale-804916e7fd0d5fda38f3c6771fa3a8ede6784ac2.tar.gz
Merge pull request #1083 from Freescale/backport-1080-to-kirkstone
[Backport kirkstone] Weston upgrade for NXP 5.15.5-1.0.0
-rw-r--r--recipes-graphics/wayland/weston_9.0.0.imx.bb2
-rw-r--r--recipes-graphics/xwayland/xwayland/0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch31
-rw-r--r--recipes-graphics/xwayland/xwayland/0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch39
-rw-r--r--recipes-graphics/xwayland/xwayland_%.bbappend16
4 files changed, 83 insertions, 5 deletions
diff --git a/recipes-graphics/wayland/weston_9.0.0.imx.bb b/recipes-graphics/wayland/weston_9.0.0.imx.bb
index a8df8b10..228cf4fa 100644
--- a/recipes-graphics/wayland/weston_9.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_9.0.0.imx.bb
@@ -163,7 +163,7 @@ SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
163 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \ 163 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \
164" 164"
165SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} " 165SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} "
166SRCREV = "26da63a46b926c8301d8c271f6869c893cc35afa" 166SRCREV = "7859a762617682bd804e210ad3bda6bdcd3ea24a"
167S = "${WORKDIR}/git" 167S = "${WORKDIR}/git"
168 168
169# Disable OpenGL for parts with GPU support for 2D but not 3D 169# Disable OpenGL for parts with GPU support for 2D but not 3D
diff --git a/recipes-graphics/xwayland/xwayland/0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch b/recipes-graphics/xwayland/xwayland/0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch
new file mode 100644
index 00000000..c1e8ae11
--- /dev/null
+++ b/recipes-graphics/xwayland/xwayland/0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch
@@ -0,0 +1,31 @@
1From e75a4d7b4474529967490de6e75ae4f1b7128937 Mon Sep 17 00:00:00 2001
2From: Xianzhong <xianzhong.li@nxp.com>
3Date: Sat, 22 Jan 2022 17:57:59 +0800
4Subject: [PATCH 1/3] Prefer to create GLES2 context for glamor EGL
5
6created the initial patch for xwayland-21.1.2
7
8Upstream-Status: Inappropriate [embedded specific]
9Signed-off-by: Xianzhong <xianzhong.li@nxp.com>
10---
11 hw/xwayland/xwayland-glamor-gbm.c | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/hw/xwayland/xwayland-glamor-gbm.c b/hw/xwayland/xwayland-glamor-gbm.c
15index 12d820e44..8a89919be 100644
16--- a/hw/xwayland/xwayland-glamor-gbm.c
17+++ b/hw/xwayland/xwayland-glamor-gbm.c
18@@ -866,8 +866,8 @@ xwl_glamor_gbm_init_egl(struct xwl_screen *xwl_screen)
19 goto error;
20 }
21
22- if (!xwl_glamor_try_big_gl_api(xwl_screen) &&
23- !xwl_glamor_try_gles_api(xwl_screen)) {
24+ if (!xwl_glamor_try_gles_api(xwl_screen) &&
25+ !xwl_glamor_try_big_gl_api(xwl_screen)) {
26 ErrorF("Cannot use neither GL nor GLES2\n");
27 goto error;
28 }
29--
302.17.1
31
diff --git a/recipes-graphics/xwayland/xwayland/0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch b/recipes-graphics/xwayland/xwayland/0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch
new file mode 100644
index 00000000..1c6cf2ec
--- /dev/null
+++ b/recipes-graphics/xwayland/xwayland/0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch
@@ -0,0 +1,39 @@
1From 4508e54dae9d2884b2d6ccca13450b25d509cc9a Mon Sep 17 00:00:00 2001
2From: Xianzhong <xianzhong.li@nxp.com>
3Date: Thu, 5 Aug 2021 16:57:43 +0800
4Subject: [PATCH 3/3] glamor: Fix fbo pixmap format with GL_BGRA_EXT
5
6Red and Blue channels are swizzled in GLES path,
7Fix color inverse problem with ximagesink command:
8gst-launch-1.0 videotestsrc pattern=6 num-buffers=1 ! video/x-raw,format=BGRx ! videoconvert ! ximagesink display=:0 -v
9
10This fix requires GL_EXT_texture_format_BGRA8888 extension, not applicable for upstream.
11
12Upstream-Status: Inappropriate [embedded specific]
13Signed-off-by: Xianzhong <xianzhong.li@nxp.com>
14---
15 glamor/glamor.c | 7 +++++++
16 1 file changed, 7 insertions(+)
17
18Index: xwayland-21.1.4/glamor/glamor.c
19===================================================================
20--- xwayland-21.1.4.orig/glamor/glamor.c
21+++ xwayland-21.1.4/glamor/glamor.c
22@@ -586,10 +586,17 @@ glamor_setup_formats(ScreenPtr screen)
23
24 if (glamor_priv->is_gles) {
25 assert(X_BYTE_ORDER == X_LITTLE_ENDIAN);
26+#if GL_EXT_texture_format_BGRA8888
27+ glamor_add_format(screen, 24, PICT_x8r8g8b8,
28+ GL_BGRA_EXT, GL_BGRA_EXT, GL_UNSIGNED_BYTE, TRUE);
29+ glamor_add_format(screen, 32, PICT_a8r8g8b8,
30+ GL_BGRA_EXT, GL_BGRA_EXT, GL_UNSIGNED_BYTE, TRUE);
31+#else
32 glamor_add_format(screen, 24, PICT_x8b8g8r8,
33 GL_RGBA8, GL_RGBA, GL_UNSIGNED_BYTE, TRUE);
34 glamor_add_format(screen, 32, PICT_a8b8g8r8,
35 GL_RGBA8, GL_RGBA, GL_UNSIGNED_BYTE, TRUE);
36+#endif
37 } else {
38 glamor_add_format(screen, 24, PICT_x8r8g8b8,
39 GL_RGBA, GL_BGRA, GL_UNSIGNED_INT_8_8_8_8_REV, TRUE);
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend
index c63212d0..69063121 100644
--- a/recipes-graphics/xwayland/xwayland_%.bbappend
+++ b/recipes-graphics/xwayland/xwayland_%.bbappend
@@ -1,4 +1,12 @@
1IMX_OPENGL_PKGCONFIGS_REMOVE = "" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2IMX_OPENGL_PKGCONFIGS_REMOVE:imxgpu = "glamor" 2
3OPENGL_PKGCONFIGS:remove:mx6-nxp-bsp = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" 3SRC_URI:append:imxgpu = " \
4OPENGL_PKGCONFIGS:remove:mx7-nxp-bsp = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" 4 file://0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch \
5 file://0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch \
6"
7
8OPENGL_PKGCONFIGS:remove:imxgpu = "${OPENGL_PKGCONFIGS_REMOVE_IMXGPU}"
9OPENGL_PKGCONFIGS_REMOVE_IMXGPU = ""
10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx"
11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx"
12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx"