summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-05-11 13:09:37 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-05-11 20:41:15 +0000
commit075189e8024f88228b02657372bf0e99c64e6ede (patch)
tree41883103603966db65f331c5036db5c19ce93fd2
parentf981ad9009073062352a187e4251abc5f7e589c5 (diff)
downloadmeta-freescale-075189e8024f88228b02657372bf0e99c64e6ede.tar.gz
imx-gpu-g2d: Fix install for multilib
The do_install task doesn't account for multilib. Fix it by using the libdir variable. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit f20a173501a4839b803765b57e3afc5f9f5a2147)
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb
index 90231106..1f3c2e60 100644
--- a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb
+++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb
@@ -1,5 +1,5 @@
1# Copyright (C) 2016 Freescale Semiconductor 1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP 2# Copyright 2017-2022 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA. 3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms) 4# Released under the MIT license (see COPYING.MIT for the terms)
5 5
@@ -22,7 +22,10 @@ S = "${WORKDIR}/${FSLBIN_NAME}"
22inherit fsl-eula-unpack 22inherit fsl-eula-unpack
23 23
24do_install () { 24do_install () {
25 cp -r -d --no-preserve=ownership ${S}/g2d/* ${D} 25 install -d ${D}${libdir}
26 install -d ${D}${includedir}
27 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
28 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
26} 29}
27 30
28INSANE_SKIP:${PN} = "ldflags" 31INSANE_SKIP:${PN} = "ldflags"