summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-10 14:28:22 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitce161362d48cd863cd09a735e5609817f46087bf (patch)
tree1c5be12e8ee747de847e23ba58718ecef246f245
parent02222424d6d8592385c603a2afc34450d46efe4e (diff)
downloadmeta-freescale-ce161362d48cd863cd09a735e5609817f46087bf.tar.gz
Drop i.MX31 and i.MX35 support
The i.MX31 and i.MX35 has been barely used and without much community coverage since its inclusion making them untested boards. There is no reason to keep the support for those SoCs in the BSP layer as those are virtually not tested and unkown to be working or not. The metadata related to the i.MX3 SoC family has been removed in this commit so if someone ever wants to bring it back it is easy to find out all the necessary changes. Change-Id: I808bf7d1cfa97eb7d444fba711a93b1e074d5f4d Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--conf/machine/imx31pdk.conf24
-rw-r--r--conf/machine/imx35pdk.conf25
-rw-r--r--conf/machine/include/imx-base.inc5
-rw-r--r--recipes-bsp/imx-test/imx-test_00.00.00.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc.inc2
-rw-r--r--recipes-kernel/linux/linux-fslc_4.1.bb2
6 files changed, 3 insertions, 57 deletions
diff --git a/conf/machine/imx31pdk.conf b/conf/machine/imx31pdk.conf
deleted file mode 100644
index cf368eb8..00000000
--- a/conf/machine/imx31pdk.conf
+++ /dev/null
@@ -1,24 +0,0 @@
1#@TYPE: Machine
2#@NAME: Freescale i.MX31 Platform Development Kit
3#@SOC: i.MX31
4#@DESCRIPTION: Machine configuration for Freescale i.MX31 Platform Development Kit
5
6include conf/machine/include/imx-base.inc
7require conf/machine/include/tune-arm1136jf-s.inc
8
9SOC_FAMILY = "mx3:mx31"
10
11GUI_MACHINE_CLASS = "smallscreen"
12
13UBOOT_MAKE_TARGET = "u-boot-with-spl.bin"
14UBOOT_SUFFIX = "bin"
15UBOOT_MACHINE = "mx31pdk_config"
16UBOOT_BINARY = "u-boot-with-spl.bin"
17KERNEL_IMAGETYPE = "uImage"
18
19IMAGE_FSTYPES = "ubi jffs2 tar.bz2"
20MKUBIFS_ARGS = "-m 2048 -e 129024 -c 2030"
21UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
22
23MACHINE_FEATURES += "ext3 bluetooth ext2 screen"
24
diff --git a/conf/machine/imx35pdk.conf b/conf/machine/imx35pdk.conf
deleted file mode 100644
index a3fc60cb..00000000
--- a/conf/machine/imx35pdk.conf
+++ /dev/null
@@ -1,25 +0,0 @@
1#@TYPE: Machine
2#@NAME: Freescale i.MX35 Platform Development Kit
3#@SOC: i.MX35
4#@DESCRIPTION: Machine configuration for Freescale i.MX35 Platform Development Kit
5
6include conf/machine/include/imx-base.inc
7require conf/machine/include/tune-arm1136jf-s.inc
8
9SOC_FAMILY = "mx3:mx35"
10
11UBOOT_MACHINE = "mx35pdk_config"
12UBOOT_SUFFIX = "bin"
13UBOOT_BINARY = "u-boot.bin"
14UBOOT_MAKE_TARGET = "u-boot.bin"
15KERNEL_IMAGETYPE = "uImage"
16
17GUI_MACHINE_CLASS = "bigscreen"
18
19ROOT_FLASH_SIZE = "256"
20
21JFFS2_ERASEBLOCK = "0x20000"
22
23IMAGE_FSTYPES += "jffs2 tar.bz2"
24
25MACHINE_FEATURES += "ext2 ext3 screen"
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index ecb2f772..fba594dd 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -11,7 +11,6 @@ PREFERRED_PROVIDER_virtual/bootloader ??= "u-boot-fslc"
11UBOOT_MAKE_TARGET = "u-boot.imx" 11UBOOT_MAKE_TARGET = "u-boot.imx"
12UBOOT_SUFFIX ?= "imx" 12UBOOT_SUFFIX ?= "imx"
13 13
14UBOOT_ENTRYPOINT_mx3 = "0x80008000"
15UBOOT_ENTRYPOINT_mx51 = "0x90008000" 14UBOOT_ENTRYPOINT_mx51 = "0x90008000"
16UBOOT_ENTRYPOINT_mx53 = "0x70008000" 15UBOOT_ENTRYPOINT_mx53 = "0x70008000"
17UBOOT_ENTRYPOINT_mx6 = "0x10008000" 16UBOOT_ENTRYPOINT_mx6 = "0x10008000"
@@ -43,7 +42,6 @@ DEFAULTTUNE_mx6 ?= "cortexa9thf-neon"
43 42
44# Sub-architecture support 43# Sub-architecture support
45MACHINE_SOCARCH_SUFFIX ?= "" 44MACHINE_SOCARCH_SUFFIX ?= ""
46MACHINE_SOCARCH_SUFFIX_mx3 = "-mx3"
47MACHINE_SOCARCH_SUFFIX_mx5 = "-mx5" 45MACHINE_SOCARCH_SUFFIX_mx5 = "-mx5"
48MACHINE_SOCARCH_SUFFIX_mx6q = "-mx6qdl" 46MACHINE_SOCARCH_SUFFIX_mx6q = "-mx6qdl"
49MACHINE_SOCARCH_SUFFIX_mx6dl = "-mx6qdl" 47MACHINE_SOCARCH_SUFFIX_mx6dl = "-mx6qdl"
@@ -67,8 +65,6 @@ MACHINE_FIRMWARE_append_mx53 = " firmware-imx-vpu-imx53 firmware-imx-sdma-imx53"
67MACHINE_FIRMWARE_append_mx51 = " firmware-imx-vpu-imx51 firmware-imx-sdma-imx51" 65MACHINE_FIRMWARE_append_mx51 = " firmware-imx-vpu-imx51 firmware-imx-sdma-imx51"
68 66
69# FIXME: Needs addition of firmware-imx of official BSPs 67# FIXME: Needs addition of firmware-imx of official BSPs
70#MACHINE_FIRMWARE_append_mx35 = " firmware-imx-sdma-imx35"
71#MACHINE_FIRMWARE_append_mx31 = " firmware-imx-sdma-imx31"
72#MACHINE_FIRMWARE_append_mx27 = " firmware-imx-vpu-imx27" 68#MACHINE_FIRMWARE_append_mx27 = " firmware-imx-vpu-imx27"
73#MACHINE_FIRMWARE_append_mx25 = " firmware-imx-sdma-imx25" 69#MACHINE_FIRMWARE_append_mx25 = " firmware-imx-sdma-imx25"
74 70
@@ -111,7 +107,6 @@ PREFERRED_PROVIDER_virtual/libg2d_mx6 ?= "imx-gpu-viv"
111 107
112# Handle default kernel 108# Handle default kernel
113IMX_DEFAULT_KERNEL = "linux-imx" 109IMX_DEFAULT_KERNEL = "linux-imx"
114IMX_DEFAULT_KERNEL_mx3 = "linux-fslc"
115IMX_DEFAULT_KERNEL_mx6 = "linux-fslc-mx6" 110IMX_DEFAULT_KERNEL_mx6 = "linux-fslc-mx6"
116PREFERRED_PROVIDER_virtual/kernel ??= "${IMX_DEFAULT_KERNEL}" 111PREFERRED_PROVIDER_virtual/kernel ??= "${IMX_DEFAULT_KERNEL}"
117 112
diff --git a/recipes-bsp/imx-test/imx-test_00.00.00.bb b/recipes-bsp/imx-test/imx-test_00.00.00.bb
index f38dc67f..c29e6a62 100644
--- a/recipes-bsp/imx-test/imx-test_00.00.00.bb
+++ b/recipes-bsp/imx-test/imx-test_00.00.00.bb
@@ -7,4 +7,4 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ad
7ALLOW_EMPTY_${PN} = "1" 7ALLOW_EMPTY_${PN} = "1"
8 8
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf50|vf60)" 10COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf50|vf60)"
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc.inc
index 07fb5074..a9b35a64 100644
--- a/recipes-bsp/u-boot/u-boot-fslc.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc.inc
@@ -11,7 +11,7 @@ was submitted for revision and it takes some time to become part of a stable \
11version, or because it is not applicable for upstreaming." 11version, or because it is not applicable for upstreaming."
12LICENSE = "GPLv2+" 12LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919" 13LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
14COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf)" 14COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf)"
15 15
16DEPENDS_mxs += "elftosb-native openssl-native" 16DEPENDS_mxs += "elftosb-native openssl-native"
17 17
diff --git a/recipes-kernel/linux/linux-fslc_4.1.bb b/recipes-kernel/linux/linux-fslc_4.1.bb
index 84edf118..60e68ab6 100644
--- a/recipes-kernel/linux/linux-fslc_4.1.bb
+++ b/recipes-kernel/linux/linux-fslc_4.1.bb
@@ -14,4 +14,4 @@ PV = "4.1+git${SRCPV}"
14SRCBRANCH = "patches-4.1" 14SRCBRANCH = "patches-4.1"
15SRCREV = "665a389b8e62c444969ac65e3e0eda5d8c13ea24" 15SRCREV = "665a389b8e62c444969ac65e3e0eda5d8c13ea24"
16 16
17COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6)" 17COMPATIBLE_MACHINE = "(mxs|mx5|mx6)"