summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-05-16 13:58:31 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2022-06-16 16:53:22 -0300
commit5fe30678d5a49825b0474c8951e51aaca7cbcc82 (patch)
treec6a6f3bd3d051ecae587aaa45be41359d52acf50
parent6752c742a2076b35c2e2e57538126c5cf0fdefc0 (diff)
downloadmeta-freescale-5fe30678d5a49825b0474c8951e51aaca7cbcc82.tar.gz
imx-atf: Suppress array-bounds error
The array-bounds error is triggered now in cases where it was silent before, causing errors like: ``` plat/imx/imx8m/hab.c: In function 'imx_hab_handler': plat/imx/imx8m/hab.c:64:57: error: array subscript 0 is outside array bounds of 'uint32_t[0]' {aka 'unsigned int[]'} [-Werror=array-bounds] 64 | #define HAB_RVT_CHECK_TARGET_ARM64 ((unsigned long)*(uint32_t *)(HAB_RVT_BASE + 0x18)) | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ``` It appears that these new cases will be silenced soon in gcc [1], so for now just silence the warning locally as workaround. [1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99578#c39 Fixes: #1084 Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit dc3cb910f49fc50de9539902b4ecef159603b426)
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch42
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb2
2 files changed, 43 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch b/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch
new file mode 100644
index 00000000..37b5ce6f
--- /dev/null
+++ b/recipes-bsp/imx-atf/imx-atf/0001-Makefile-Suppress-array-bounds-error.patch
@@ -0,0 +1,42 @@
1From 85f576054a4d5496706bbd37a520942f51cb74b9 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Mon, 16 May 2022 13:45:16 -0500
4Subject: [PATCH] Makefile: Suppress array-bounds error
5
6The array-bounds error is triggered now in cases where it was silent before,
7causing errors like:
8
9```
10plat/imx/imx8m/hab.c: In function 'imx_hab_handler':
11plat/imx/imx8m/hab.c:64:57: error: array subscript 0 is outside array bounds of 'uint32_t[0]' {aka 'unsigned int[]'} [-Werror=array-bounds]
12 64 | #define HAB_RVT_CHECK_TARGET_ARM64 ((unsigned long)*(uint32_t *)(HAB_RVT_BASE + 0x18))
13 | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
14```
15
16It appears that these new cases will be silenced soon in gcc [1], so for
17now just silence the warning locally as a workaround.
18
19[1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99578#c39
20
21Upstream-Status: Inappropriate [other]
22Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
23---
24 Makefile | 2 +-
25 1 file changed, 1 insertion(+), 1 deletion(-)
26
27diff --git a/Makefile b/Makefile
28index c87c3ae08..2d6b90f47 100644
29--- a/Makefile
30+++ b/Makefile
31@@ -346,7 +346,7 @@ WARNINGS += -Wshift-overflow -Wshift-sign-overflow \
32 endif
33
34 ifneq (${E},0)
35-ERRORS := -Werror
36+ERRORS := -Werror -Wno-error=array-bounds
37 endif
38
39 CPPFLAGS = ${DEFINES} ${INCLUDES} ${MBEDTLS_INC} -nostdinc \
40--
412.17.1
42
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index dd718289..86dca9dd 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -9,7 +9,7 @@ PV .= "+git${SRCPV}"
9 9
10SRCBRANCH = "lf_v2.4" 10SRCBRANCH = "lf_v2.4"
11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ 11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
12" 12 file://0001-alsa-state-Remove-PCM-devices-mapped-by-5.15-kernel.patch"
13SRCREV = "05f788b9bbb13d002997e35008a4b945f7e2957b" 13SRCREV = "05f788b9bbb13d002997e35008a4b945f7e2957b"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"