summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-05-02 13:28:50 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-05-05 17:21:28 +0000
commita3893814e788d56a5f4f9469c49529ff5ce247f0 (patch)
treeefeb5ad34d5e4474581cd3cb8785dd18d9b57a02
parent61bae3904e74f15cfa050e8d9609a04ded593634 (diff)
downloadmeta-freescale-a3893814e788d56a5f4f9469c49529ff5ce247f0.tar.gz
linux-imx-headers: Fix do_install
- Fix logic copied from linux-libc-headers to work on B folder - Add comments to highlight logic copied from linux-libc-headers - Fix non-inclusive language Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 6d0c1149440511c98fea305f0346b23c028dea59)
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5.15.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_5.15.bb b/recipes-kernel/linux/linux-imx-headers_5.15.bb
index b7fea42c..9fa78171 100644
--- a/recipes-kernel/linux/linux-imx-headers_5.15.bb
+++ b/recipes-kernel/linux/linux-imx-headers_5.15.bb
@@ -39,17 +39,21 @@ IMX_UAPI_HEADERS = " \
39 39
40do_install() { 40do_install() {
41 # We install all headers inside of B so we can copy only the 41 # We install all headers inside of B so we can copy only the
42 # whitelisted ones, and there is no risk of a new header to be 42 # i.MX-specific ones, and there is no risk of a new header to be
43 # installed by mistake. 43 # installed by mistake.
44 oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix} 44 oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
45 45
46 ################################################
47 # BEGIN Copy of exceptional logic from linux-libc-headers
46 # Kernel should not be exporting this header 48 # Kernel should not be exporting this header
47 rm -f ${D}${exec_prefix}/include/scsi/scsi.h 49 rm -f ${B}${exec_prefix}/include/scsi/scsi.h
48 50
49 # The ..install.cmd conflicts between various configure runs 51 # The ..install.cmd conflicts between various configure runs
50 find ${D}${includedir} -name ..install.cmd | xargs rm -f 52 find ${B}${includedir} -name ..install.cmd | xargs rm -f
53 # END Copy from linux-libc-headers
54 ################################################
51 55
52 # Install whitelisted headers only 56 # Install i.MX-specific headers only
53 for h in ${IMX_UAPI_HEADERS}; do 57 for h in ${IMX_UAPI_HEADERS}; do
54 install -D -m 0644 ${B}${includedir}/linux/$h \ 58 install -D -m 0644 ${B}${includedir}/linux/$h \
55 ${D}${includedir}/imx/linux/$h 59 ${D}${includedir}/imx/linux/$h