summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2022-04-07 13:41:12 -0400
committerTrevor Woerner <twoerner@gmail.com>2022-04-07 13:41:12 -0400
commit83d3b9c2c14a875fb001db46f2b647d19787294f (patch)
tree6bd38402ffd813bf8f5bd470ee12b744c3017de1
parentb986705c8e81b4b60941d1f2cff74a8f02c99942 (diff)
downloadmeta-freescale-83d3b9c2c14a875fb001db46f2b647d19787294f.tar.gz
u-boot-fslc-mxsboot: add dependency on gnutls-native
gnutls is now required in order to build one of the host tools which are part of U-Boot. | .../build/tmp-glibc/work/x86_64-linux/u-boot-fslc-mxsboot-native/v2022.04+gitAUTOINC+f885198273-r0/git/tools/mkeficapsule.c:21:10: fatal error: gnutls/gnutls.h: No such file or directory | #include <gnutls/gnutls.h> | ^~~~~~~~~~~~~~~~~ | compilation terminated. | make[2]: *** [scripts/Makefile.host:95: tools/mkeficapsule] Error 1 | make[2]: *** Waiting for unfinished jobs.... | make[1]: *** [.../build/tmp-glibc/work/x86_64-linux/u-boot-fslc-mxsboot-native/v2022.04+gitAUTOINC+f885198273-r0/git/Makefile:1894: tools] Error 2 | make[1]: Leaving directory '.../build/tmp-glibc/work/x86_64-linux/u-boot-fslc-mxsboot-native/v2022.04+gitAUTOINC+f885198273-r0/build' | make: *** [Makefile:177: sub-make] Error 2 | make: Leaving directory '.../build/tmp-glibc/work/x86_64-linux/u-boot-fslc-mxsboot-native/v2022.04+gitAUTOINC+f885198273-r0/git' | ERROR: oe_runmake failed | WARNING: .../build/tmp-glibc/work/x86_64-linux/u-boot-fslc-mxsboot-native/v2022.04+gitAUTOINC+f885198273-r0/temp/run.do_compile.24796:186 exit 1 from 'exit 1' Signed-off-by: Trevor Woerner <twoerner@gmail.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.04.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.04.bb
index 0a0a1d9c..2660df9e 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.04.bb
@@ -3,7 +3,7 @@ require u-boot-fslc-common_${PV}.inc
3DESCRIPTION = "U-boot bootloader mxsboot tool" 3DESCRIPTION = "U-boot bootloader mxsboot tool"
4SECTION = "bootloader" 4SECTION = "bootloader"
5 5
6DEPENDS = "bison-native dtc openssl" 6DEPENDS = "bison-native gnutls-native dtc openssl"
7 7
8PROVIDES = "u-boot-mxsboot" 8PROVIDES = "u-boot-mxsboot"
9 9