summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-03-29 20:11:45 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-04-04 16:57:41 -0500
commit782a476b459c37d1c406d0d82207250f70c29712 (patch)
tree50b751363c3785d95386101998d3c6f37644a661
parent200e8ad05248ef0bdc64a6eb869817a39aac21e9 (diff)
downloadmeta-freescale-782a476b459c37d1c406d0d82207250f70c29712.tar.gz
gstreamer1.0-plugins-base: Upgrade 1.18.0.imx -> 1.18.5.imx
Also separate the base recipe copy from the overrides for ease of maintenance. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0004-glimagesink-Downrank-to-marginal.patch30
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/4ef5c91697a141fea7317aff7f0f28e5a861db99.patch48
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.%.bbappend5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb)64
4 files changed, 53 insertions, 94 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0004-glimagesink-Downrank-to-marginal.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0004-glimagesink-Downrank-to-marginal.patch
deleted file mode 100644
index 94a61465..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0004-glimagesink-Downrank-to-marginal.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From b975be9c4630536ec1315773be29900371d21930 Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex.kanavin@gmail.com>
3Date: Thu, 24 Sep 2015 19:47:32 +0300
4Subject: [PATCH] glimagesink: Downrank to marginal
5
6On desktop, where there is good OpenGL, xvimagesink will come up first,
7on other platforms, OpenGL can't be trusted because it's either software (like
8in a VM) or broken (like on embedded)., so let ximagesink come above.
9
10Upstream-Status: Submitted [https://bugzilla.gnome.org/show_bug.cgi?id=751684]
11
12Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
13
14---
15 ext/gl/gstopengl.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/ext/gl/gstopengl.c b/ext/gl/gstopengl.c
19index 302e8452c..463be9cd8 100644
20--- a/ext/gl/gstopengl.c
21+++ b/ext/gl/gstopengl.c
22@@ -127,7 +127,7 @@ plugin_init (GstPlugin * plugin)
23 #endif
24
25 if (!gst_element_register (plugin, "glimagesink",
26- GST_RANK_SECONDARY, gst_gl_image_sink_bin_get_type ())) {
27+ GST_RANK_MARGINAL, gst_gl_image_sink_bin_get_type ())) {
28 return FALSE;
29 }
30
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/4ef5c91697a141fea7317aff7f0f28e5a861db99.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/4ef5c91697a141fea7317aff7f0f28e5a861db99.patch
deleted file mode 100644
index 0fa3dd30..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/4ef5c91697a141fea7317aff7f0f28e5a861db99.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 1718197bf6ebf3d8784a55126609aa8770fff682 Mon Sep 17 00:00:00 2001
2From: Xavier Claessens <xavier.claessens@collabora.com>
3Date: Mon, 26 Apr 2021 14:25:03 -0400
4Subject: [PATCH] gstgl: Fix build when Meson >= 0.58.0rc1
5
6"implicit_include_directories: false" now also means that current build
7directory is not added to include paths by default any more. We have to
8add it manually because we have some custom_target() that generate
9headers in current build directory.
10
11See https://github.com/mesonbuild/meson/issues/8700.
12
13Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/1125>
14Upstream-Status: Backport
15Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
16
17---
18 gst-libs/gst/gl/meson.build | 15 ++++++++++++---
19 1 file changed, 12 insertions(+), 3 deletions(-)
20
21diff --git a/gst-libs/gst/gl/meson.build b/gst-libs/gst/gl/meson.build
22index ae19d7aca..3ad7ddcf6 100644
23--- a/gst-libs/gst/gl/meson.build
24+++ b/gst-libs/gst/gl/meson.build
25@@ -1023,11 +1023,20 @@ if build_gstgl
26 command : [mkenums, glib_mkenums, '@OUTPUT@', '@INPUT@'])
27 gen_sources = [gl_enumtypes_h]
28
29+ common_args = gst_plugins_base_args + gl_cpp_args + ['-DBUILDING_GST_GL']
30+
31+ # We have custom_target() that generate headers in the current build dir,
32+ # but with implicit_include_directories: false, meson >= 0.58.0 won't include
33+ # it by default. We cannot use include_directories('.') here because it would
34+ # also include current source dir which is what we want to avoid because
35+ # case-insensitive FS would include gst-libs/gl/egl/egl.h as EGL/egl.h.
36+ common_args += '-I@0@'.format(meson.current_build_dir())
37+
38 gstgl = library('gstgl-' + api_version,
39 gl_sources, gl_egl_sources, gl_x11_sources, gl_wayland_sources, gl_priv_sources, gl_enumtypes_c, gl_enumtypes_h,
40- c_args : gst_plugins_base_args + gl_cpp_args + ['-DBUILDING_GST_GL'],
41- cpp_args : gst_plugins_base_args + gl_cpp_args + ['-DBUILDING_GST_GL'],
42- objc_args : gst_plugins_base_args + gl_cpp_args + gl_objc_args + ['-DBUILDING_GST_GL'],
43+ c_args : common_args,
44+ cpp_args : common_args,
45+ objc_args : common_args + gl_objc_args,
46 include_directories : [configinc, libsinc, gl_includes],
47 version : libversion,
48 soversion : soversion,
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.%.bbappend
deleted file mode 100644
index 1c62f31d..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1PACKAGECONFIG_GL:imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl', '', d)}"
2PACKAGECONFIG_GL:imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
3
4# For mainline BSP we need to enable 'gbm' Window system
5PACKAGECONFIG_GL:use-mainline-bsp = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl gbm', '', d)}"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb
index b297a178..03bfa129 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb
@@ -1,3 +1,10 @@
1# This recipe is for the i.MX fork of gstreamer1.0-plugins-base. For ease of
2# maintenance, the top section is a verbatim copy of an OE-core
3# recipe. The second section customizes the recipe for i.MX.
4
5########### OE-core copy ##################
6# Upstream hash: bb6ddc3691ab04162ec5fd69a2d5e7876713fd15
7
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc 8require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2 9
3DESCRIPTION = "'Base' GStreamer plugins and helper libraries" 10DESCRIPTION = "'Base' GStreamer plugins and helper libraries"
@@ -6,23 +13,20 @@ BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues
6LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later" 13LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d" 14LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
8 15
9GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https;branch=master" 16SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
10SRCBRANCH = "MM_04.06.01_2105_L5.10.y" 17 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \
11SRC_URI = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \
12 file://0003-viv-fb-Make-sure-config.h-is-included.patch \ 18 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
19 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \
13 file://0004-glimagesink-Downrank-to-marginal.patch \ 20 file://0004-glimagesink-Downrank-to-marginal.patch \
14 file://4ef5c91697a141fea7317aff7f0f28e5a861db99.patch \ 21 file://4ef5c91697a141fea7317aff7f0f28e5a861db99.patch \
15 " 22 "
16SRCREV = "69554a26c932481acb7c5691038c367eca60e5bc" 23SRC_URI[sha256sum] = "29e53229a84d01d722f6f6db13087231cdf6113dd85c25746b9b58c3d68e8323"
17 24
18S = "${WORKDIR}/git" 25S = "${WORKDIR}/gst-plugins-base-${PV}"
19 26
20DEPENDS += "iso-codes util-linux zlib" 27DEPENDS += "iso-codes util-linux zlib"
21DEPENDS:append:imxgpu2d = " virtual/libg2d"
22 28
23inherit gobject-introspection use-imx-headers 29inherit gobject-introspection
24
25DEFAULT_PREFERENCE = "-1"
26 30
27PACKAGES_DYNAMIC =+ "^libgst.*" 31PACKAGES_DYNAMIC =+ "^libgst.*"
28 32
@@ -40,7 +44,6 @@ PACKAGECONFIG ??= " \
40 44
41OPENGL_APIS = 'opengl gles2' 45OPENGL_APIS = 'opengl gles2'
42OPENGL_PLATFORMS = 'egl' 46OPENGL_PLATFORMS = 'egl'
43OPENGL_WINSYS = 'x11 wayland gbm viv-fb'
44 47
45X11DEPENDS = "virtual/libx11 libsm libxrender libxv" 48X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
46X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled" 49X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled"
@@ -80,7 +83,6 @@ EXTRA_OEMESON += " \
80 ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \ 83 ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \
81 ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \ 84 ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \
82 ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \ 85 ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \
83 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \
84" 86"
85 87
86FILES:${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h" 88FILES:${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h"
@@ -99,4 +101,44 @@ def get_opengl_cmdline_list(switch_name, options, d):
99 101
100CVE_PRODUCT += "gst-plugins-base" 102CVE_PRODUCT += "gst-plugins-base"
101 103
104########### End of OE-core copy ###########
105
106########### i.MX overrides ################
107
108DEFAULT_PREFERENCE = "-1"
109
110SRC_URI:remove = " \
111 https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
112 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \
113 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \
114 file://0004-glimagesink-Downrank-to-marginal.patch \
115 file://4ef5c91697a141fea7317aff7f0f28e5a861db99.patch \
116"
117GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
118SRCBRANCH = "MM_04.06.04_2112_L5.15.y"
119SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} "
120SRCREV = "d8f5d6e1d477a299ccb7f4ba7aacd36ff5e39f8b"
121
122S = "${WORKDIR}/git"
123
124inherit use-imx-headers
125
126PACKAGECONFIG_GL:imxgpu2d = \
127 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl viv-fb', '', d)}"
128PACKAGECONFIG_GL:imxgpu3d = \
129 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl viv-fb', '', d)}"
130PACKAGECONFIG_GL:use-mainline-bsp = \
131 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl gbm', '', d)}"
132
133PACKAGECONFIG_REMOVE ?= "jpeg"
134PACKAGECONFIG:remove = "${PACKAGECONFIG_REMOVE}"
135PACKAGECONFIG:append:imxgpu2d = " g2d"
136
137PACKAGECONFIG[g2d] = ",,virtual/libg2d"
138PACKAGECONFIG[viv-fb] = ",,virtual/libgles2"
139
140EXTRA_OEMESON += "-Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}""
141
102COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 142COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
143
144########### End of i.MX overrides #########