summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2017-01-13 17:43:27 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2017-01-17 09:31:38 -0200
commit682cfd54dbd98f0e51b3598df25bd7e6d56439b0 (patch)
treecf24c10ed3192b025ebd5fffb0c87fb2b923f81b
parent022d7611ec0c76578ef90c3078849a4b9e91f483 (diff)
downloadmeta-freescale-682cfd54dbd98f0e51b3598df25bd7e6d56439b0.tar.gz
u-boot-qoriq: Fix python function for fsl-lsch2-32b arch
Add missing argument in function getVar() to avoid error: Exception: TypeError: getVar() missing 1 required positional argument: 'expand' Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb
index 0b392754..56002146 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.09.bb
@@ -43,10 +43,10 @@ python () {
43 elif "fsl-lsch2-32b:" in arch: 43 elif "fsl-lsch2-32b:" in arch:
44 if not "lib64" in ml: 44 if not "lib64" in ml:
45 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") 45 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
46 sys_multilib = 'aarch64' + d.getVar('TARGET_VENDOR') + 'mllib64-linux' 46 sys_multilib = 'aarch64' + d.getVar('TARGET_VENDOR', False) + 'mllib64-linux'
47 d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc') 47 d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc')
48 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/' + sys_multilib) 48 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE', False) + '/' + sys_multilib)
49 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib64-' + d.getVar("MACHINE")) 49 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib64-' + d.getVar("MACHINE", False))
50 d.setVar("WRAP_TARGET_PREFIX", sys_multilib + '-') 50 d.setVar("WRAP_TARGET_PREFIX", sys_multilib + '-')
51} 51}
52 52