summaryrefslogtreecommitdiffstats
path: root/recipes-test/virt-test/virt-test-libvirt_git.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:57:02 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:57:02 +0200
commit74d51c8c3e18a8b6738aff0c6f7ff706fd70eaa6 (patch)
treed4b576b12f8fe930ac8a76056ecaa356ec0ec133 /recipes-test/virt-test/virt-test-libvirt_git.bb
downloadmeta-vt-74d51c8c3e18a8b6738aff0c6f7ff706fd70eaa6.tar.gz
initial commit for Enea Linux 4.0daisy-enea
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-test/virt-test/virt-test-libvirt_git.bb')
-rw-r--r--recipes-test/virt-test/virt-test-libvirt_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-test/virt-test/virt-test-libvirt_git.bb b/recipes-test/virt-test/virt-test-libvirt_git.bb
new file mode 100644
index 0000000..c14a242
--- /dev/null
+++ b/recipes-test/virt-test/virt-test-libvirt_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Linux Virtualization Tests - libvirt tests"
2DESCRIPTION = "Libvirt tests for the virt-test test framework"
3HOMEPAGE = "https://github.com/autotest/tp-libvirt"
4SECTION = "console/tests"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=17f870b05bb22b9c31f4d593711edf58"
7
8RDEPENDS_${PN} = "virt-test"
9
10# Use date of commit pointed to by SRCREV
11PV = "2014.03.07"
12SRCREV = "9d4c278ed36e8bd4104cf94e77dc7e89f4ccb917"
13
14SRC_URI = "git://github.com/autotest/tp-libvirt"
15
16S = "${WORKDIR}/git"
17B = "${S}"
18
19DESTDIR = "/opt/virt-test/test-providers.d/downloads/io-github-autotest-libvirt/"
20
21FILES_${PN} += "${DESTDIR}"
22
23do_install() {
24 install -d ${D}/${DESTDIR}
25 cp -r --preserve=mode,links ${B}/* ${D}/${DESTDIR}
26}