summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu/qemu_2.3.0.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:22:28 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:22:28 +0200
commit31ce2d1a14de6d8439829dc8a046aeaeef734461 (patch)
treecaf52884a4410ef7d579f4eb63cf0a7a6001c413 /recipes-devtools/qemu/qemu_2.3.0.bb
downloadmeta-vt-31ce2d1a14de6d8439829dc8a046aeaeef734461.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'recipes-devtools/qemu/qemu_2.3.0.bb')
-rw-r--r--recipes-devtools/qemu/qemu_2.3.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu_2.3.0.bb b/recipes-devtools/qemu/qemu_2.3.0.bb
new file mode 100644
index 0000000..8ef3719
--- /dev/null
+++ b/recipes-devtools/qemu/qemu_2.3.0.bb
@@ -0,0 +1,38 @@
1require recipes-devtools/qemu/qemu.inc
2
3PROVIDES = "qemu"
4
5# This is v2.3.0
6#SRCREV = "e5b3a24181ea0cebf1c5b20f44d016311b7048f0"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
9 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
10
11# Discard all files included in qemu.inc, we're not interested in them here
12# This is why it is an "=" and not _prepend or "+=" as in other recipes:
13SRC_URI = "git://git.qemu.org/qemu.git;tag=v2.3.0"
14S = "${WORKDIR}/git"
15
16DEFAULT_PREFERENCE = "-1"
17
18COMPATIBLE_HOST_class-target_mips64 = "null"
19
20# build arm emulators only
21QEMU_TARGETS = "arm aarch64"
22
23# Override --disable-glx, which now is --disable-opengl
24PACKAGECONFIG[glx] = "--enable-opengl,--disable-opengl,mesa"
25PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,mesa"
26
27FILES_${PN} += " \
28 /run \
29 /usr/share/qemu \
30 "
31
32# Our own do_install function so it doesn't try to install powerpc_rom.bin:
33do_install () {
34 export STRIP="true"
35 autotools_do_install
36 install -d ${D}${datadir}/qemu
37}
38