summaryrefslogtreecommitdiffstats
path: root/recipes-networking/dpdk/files/l2fwd-lpbk/Makefile
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:48:23 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:48:23 +0200
commit1b6242fc583a6b871304fb995af6dc211b58f69b (patch)
treeb5d434d90dedae24792906aa304897c23a134386 /recipes-networking/dpdk/files/l2fwd-lpbk/Makefile
downloadmeta-ip-1b6242fc583a6b871304fb995af6dc211b58f69b.tar.gz
initial commit for Enea Linux 4.0daisy-enea
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-networking/dpdk/files/l2fwd-lpbk/Makefile')
-rw-r--r--recipes-networking/dpdk/files/l2fwd-lpbk/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes-networking/dpdk/files/l2fwd-lpbk/Makefile b/recipes-networking/dpdk/files/l2fwd-lpbk/Makefile
new file mode 100644
index 0000000..72d56b7
--- /dev/null
+++ b/recipes-networking/dpdk/files/l2fwd-lpbk/Makefile
@@ -0,0 +1,51 @@
1# BSD LICENSE
2#
3# Copyright(c) 2010-2013 Intel Corporation. All rights reserved.
4# All rights reserved.
5#
6# Redistribution and use in source and binary forms, with or without
7# modification, are permitted provided that the following conditions
8# are met:
9#
10# * Redistributions of source code must retain the above copyright
11# notice, this list of conditions and the following disclaimer.
12# * Redistributions in binary form must reproduce the above copyright
13# notice, this list of conditions and the following disclaimer in
14# the documentation and/or other materials provided with the
15# distribution.
16# * Neither the name of Intel Corporation nor the names of its
17# contributors may be used to endorse or promote products derived
18# from this software without specific prior written permission.
19#
20# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
21# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
22# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
23# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
24# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
25# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
26# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
27# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
28# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
29# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
30# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
31#
32
33ifeq ($(RTE_SDK),)
34$(error "Please define RTE_SDK environment variable")
35endif
36
37# Default target, can be overriden by command line or environment
38RTE_TARGET ?= x86_64-default-linuxapp-gcc
39
40include $(RTE_SDK)/mk/rte.vars.mk
41
42# binary name
43APP = l2fwd-lpbk
44
45# all source are stored in SRCS-y
46SRCS-y := main.c
47
48CFLAGS += -O3
49CFLAGS += $(WERROR_FLAGS)
50
51include $(RTE_SDK)/mk/rte.extapp.mk