summaryrefslogtreecommitdiffstats
path: root/recipes-test/ddt-runner/ddt-runner.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/ddt-runner/ddt-runner.bb')
-rw-r--r--recipes-test/ddt-runner/ddt-runner.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-test/ddt-runner/ddt-runner.bb b/recipes-test/ddt-runner/ddt-runner.bb
new file mode 100644
index 0000000..f6d234e
--- /dev/null
+++ b/recipes-test/ddt-runner/ddt-runner.bb
@@ -0,0 +1,24 @@
1LICENSE = "BSD"
2LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
3INHIBIT_DEFAULT_DEPS = "1"
4
5SRC_URI = "file://ddt-runner \
6 file://scripts"
7
8FILES_${PN} += "${libdir}/${PN}"
9FILES_${PN} += "${bindir}/ddt-runner"
10
11do_install () {
12 install -D ${WORKDIR}/ddt-runner ${D}${bindir}/ddt-runner
13 if [ -d "${WORKDIR}/scripts/${MACHINE}" ]; then
14 install -d ${D}${libdir}/${PN}/scripts
15 for file in ${WORKDIR}/scripts/${MACHINE}/* ; do
16 install $file ${D}${libdir}/${PN}/scripts
17 done
18 fi
19}
20
21do_patch[noexec] = "1"
22do_configure[noexec] = "1"
23do_compile[noexec] = "1"
24do_build[noexec] = "1"