summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-keystone_3.8.4.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-keystone_3.8.4.bbappend')
-rw-r--r--recipes-kernel/linux/linux-keystone_3.8.4.bbappend24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-keystone_3.8.4.bbappend b/recipes-kernel/linux/linux-keystone_3.8.4.bbappend
new file mode 100644
index 0000000..76d0615
--- /dev/null
+++ b/recipes-kernel/linux/linux-keystone_3.8.4.bbappend
@@ -0,0 +1,24 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI += "file://fix_for_CVE-2013-2094.patch \
4 file://disable_hw_checksum_offload.patch \
5 file://set-keystone2-clock-frequency.patch \
6 "
7
8KERNEL_FEATURES = " \
9 cfg/kgdb \
10 cfg/lttng \
11 cfg/perf \
12 cfg/powertop \
13 cfg/systemtap \
14 "
15KERNEL_DEFCONFIG = "${WORKDIR}/defconfig"
16
17require kernel-configure.inc
18
19do_configure_prepend() {
20
21 configure_kernel ${KERNEL_DEFCONFIG} "${KERNEL_FEATURES}"
22
23}
24