summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-bsc913x/bsc9131rdb/0001-add-options-to-KBUILD_CFLAGS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-bsc913x/bsc9131rdb/0001-add-options-to-KBUILD_CFLAGS.patch')
-rw-r--r--recipes-kernel/linux/linux-bsc913x/bsc9131rdb/0001-add-options-to-KBUILD_CFLAGS.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-bsc913x/bsc9131rdb/0001-add-options-to-KBUILD_CFLAGS.patch b/recipes-kernel/linux/linux-bsc913x/bsc9131rdb/0001-add-options-to-KBUILD_CFLAGS.patch
new file mode 100644
index 0000000..b74d512
--- /dev/null
+++ b/recipes-kernel/linux/linux-bsc913x/bsc9131rdb/0001-add-options-to-KBUILD_CFLAGS.patch
@@ -0,0 +1,25 @@
1From: Jerry Pei <jerry.pei@enea.com>
2Date: Tue, 10 Jul 2012 11:44:18 +0800
3Subject: [PATCH] add options to KBUILD_CFLAGS
4
5Signed-off-by: Jerry Pei <jerry.pei@enea.com>
6---
7 Makefile | 2 ++
8 1 file changed, 2 insertions(+)
9
10diff --git a/Makefile b/Makefile
11index e19c848..b07ce1e 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -526,6 +526,8 @@ endif # $(dot-config)
15 # Defaults vmlinux but it is usually overridden in the arch makefile
16 all: vmlinux
17
18+KBUILD_CFLAGS += -Wno-unused-but-set-variable -Wno-error=array-bounds
19+
20 ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
21 KBUILD_CFLAGS += -Os
22 else
23--
241.7.9.5
25