summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/kernel-configure.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/kernel-configure.inc')
-rw-r--r--recipes-kernel/linux/kernel-configure.inc32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-kernel/linux/kernel-configure.inc b/recipes-kernel/linux/kernel-configure.inc
new file mode 100644
index 0000000..1e4c8a8
--- /dev/null
+++ b/recipes-kernel/linux/kernel-configure.inc
@@ -0,0 +1,32 @@
1
2SRC_URI += "file://cfg \
3 file://merge_config.sh "
4
5configure_kernel() {
6 # Add debug flavour config elements from fragments
7 # Listed in increasing priority order if conflicts are detected.
8 #
9
10 #
11 #combine features cfgs with defconfig
12 #
13 addon_features=""
14 if [ -n "${2}" ]; then
15 for feature in ${2}; do
16 addon_features="${addon_features} ${WORKDIR}/${feature}.cfg"
17 done
18 fi
19
20 O=${B} ${WORKDIR}/merge_config.sh -m ${1} ${addon_features}
21
22 mv -f ${B}/.config ${B}/.mconfig
23
24 #
25 #in linux kernel 2.6.33, kconfig does not support alldefconfig yet.
26 #
27 if [ "x${PV}" = "x2.6.33" ]; then
28 oe_runmake KCONFIG_ALLCONFIG=${B}/.mconfig O=${B} allnoconfig
29 else
30 oe_runmake KCONFIG_ALLCONFIG=${B}/.mconfig O=${B} alldefconfig
31 fi
32}