summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/files/add-no-unused-but-set-variable.patch')
-rw-r--r--recipes-kernel/linux/files/add-no-unused-but-set-variable.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch b/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch
new file mode 100644
index 0000000..5133529
--- /dev/null
+++ b/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch
@@ -0,0 +1,13 @@
1diff --git a/Makefile b/Makefile
2index e821f72..cb2fcba 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -526,6 +526,8 @@ endif # $(dot-config)
6 # Defaults vmlinux but it is usually overridden in the arch makefile
7 all: vmlinux
8
9+KBUILD_CFLAGS += -Wno-unused-but-set-variable
10+
11 ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
12 KBUILD_CFLAGS += -Os
13 else