summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/files/add-no-error-uninitialized.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/files/add-no-error-uninitialized.patch')
-rw-r--r--recipes-kernel/linux/files/add-no-error-uninitialized.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/add-no-error-uninitialized.patch b/recipes-kernel/linux/files/add-no-error-uninitialized.patch
new file mode 100644
index 0000000..a70b089
--- /dev/null
+++ b/recipes-kernel/linux/files/add-no-error-uninitialized.patch
@@ -0,0 +1,69 @@
1diff --git a/Makefile b/Makefile
2index 183eff3..88fd9c1 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -370,6 +370,7 @@ LINUXINCLUDE := \
6 KBUILD_CPPFLAGS := -D__KERNEL__
7
8 KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
9+ -Wno-error=uninitialized \
10 -fno-strict-aliasing -fno-common \
11 -Werror-implicit-function-declaration \
12 -Wno-format-security \
13diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
14index 0624909..5d13d66 100644
15--- a/arch/powerpc/Makefile
16+++ b/arch/powerpc/Makefile
17@@ -17,6 +17,7 @@ HAS_BIARCH := $(call cc-option-yn, -m32)
18 # Set default 32 bits cross compilers for vdso and boot wrapper
19 CROSS32_COMPILE ?=
20
21+KBUILD_CFLAGS += -Wno-error=uninitialized
22 CROSS32CC := $(CROSS32_COMPILE)gcc
23 CROSS32AR := $(CROSS32_COMPILE)ar
24
25@@ -67,7 +68,6 @@ LDFLAGS_vmlinux-y := -Bstatic
26 LDFLAGS_vmlinux-$(CONFIG_RELOCATABLE) := -pie
27 LDFLAGS_vmlinux := $(LDFLAGS_vmlinux-y)
28
29-LIBGCC := $(shell $(CC) $(KBUILD_CFLAGS) -print-libgcc-file-name)
30
31 ifeq ($(CONFIG_PPC64),y)
32 ifeq ($(call cc-option-yn,-mcmodel=medium),y)
33@@ -176,7 +176,6 @@ core-$(CONFIG_PERF_EVENTS) += arch/powerpc/perf/
34
35 drivers-$(CONFIG_OPROFILE) += arch/powerpc/oprofile/
36
37-libs-y += $(LIBGCC)
38
39 # Default to zImage, override when needed
40 all: zImage
41diff --git a/arch/powerpc/perf/Makefile b/arch/powerpc/perf/Makefile
42index 06dd8d5..8bf06fd 100644
43--- a/arch/powerpc/perf/Makefile
44+++ b/arch/powerpc/perf/Makefile
45@@ -1,4 +1,4 @@
46-subdir-ccflags-$(CONFIG_PPC_WERROR) := -Werror
47+subdir-ccflags-$(CONFIG_PPC_WERROR) := -Wno-error=uninitialized
48
49 obj-$(CONFIG_PERF_EVENTS) += callchain.o
50
51diff --git a/arch/powerpc/sysdev/Makefile b/arch/powerpc/sysdev/Makefile
52index fa63186..d592e84 100644
53--- a/arch/powerpc/sysdev/Makefile
54+++ b/arch/powerpc/sysdev/Makefile
55@@ -1,4 +1,4 @@
56-subdir-ccflags-$(CONFIG_PPC_WERROR) := -Werror
57+subdir-ccflags-$(CONFIG_PPC_WERROR) := -Wno-error=uninitialized
58
59 ccflags-$(CONFIG_PPC64) := $(NO_MINIMAL_TOC)
60
61@@ -67,8 +67,6 @@ endif
62
63 obj-$(CONFIG_PPC_SCOM) += scom.o
64
65-subdir-ccflags-$(CONFIG_PPC_WERROR) := -Werror
66-
67 obj-$(CONFIG_PPC_XICS) += xics/
68
69 obj-$(CONFIG_GE_FPGA) += ge/