summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/files/add-no-error-array-bounds.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/files/add-no-error-array-bounds.patch')
-rw-r--r--recipes-kernel/linux/files/add-no-error-array-bounds.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/add-no-error-array-bounds.patch b/recipes-kernel/linux/files/add-no-error-array-bounds.patch
new file mode 100644
index 0000000..57b3974
--- /dev/null
+++ b/recipes-kernel/linux/files/add-no-error-array-bounds.patch
@@ -0,0 +1,13 @@
1Index: git/Makefile
2===================================================================
3--- git.orig/Makefile
4+++ git/Makefile
5@@ -558,7 +558,7 @@ endif # $(dot-config)
6 # Defaults to vmlinux, but the arch makefile usually adds further targets
7 all: vmlinux
8
9-KBUILD_CFLAGS += -Wno-unused-but-set-variable
10+KBUILD_CFLAGS += -Wno-unused-but-set-variable -Wno-error=array-bounds
11
12 ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
13 KBUILD_CFLAGS += -Os