summaryrefslogtreecommitdiffstats
path: root/recipes-enea/linx/linx-mod_2.6.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-enea/linx/linx-mod_2.6.5.bb')
-rw-r--r--recipes-enea/linx/linx-mod_2.6.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-enea/linx/linx-mod_2.6.5.bb b/recipes-enea/linx/linx-mod_2.6.5.bb
new file mode 100644
index 0000000..6cb1266
--- /dev/null
+++ b/recipes-enea/linx/linx-mod_2.6.5.bb
@@ -0,0 +1,26 @@
1SUMMARY = "LINX for Linux fast IPC"
2DESCRIPTION = "LINX is a distributed communication protocol stack for transparent inter node and interprocess communication for a heterogeneous mix of systems."
3HOMEPAGE = "http://linx.sourceforge.net/"
4
5SECTION = "kernel/modules"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://../../COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
9
10DEPENDS = "linux-libc-headers linx"
11RRECOMMENDS_${PN} = "linx kmod"
12
13SRC_URI = "http://linux.enea.com/linx/linx-${PV}.tar.gz \
14 file://linx-kernel-modules.patch \
15 file://support-for-3.11-kernel-versions.patch \
16 "
17SRC_URI[md5sum] = "986191fbceff8e15c03dedc5e544e42e"
18SRC_URI[sha256sum] = "ee51c905115dbf6e25b5980006994a81732b1c0aac460f16a6f0582bc1114954"
19
20S = "${WORKDIR}/linx-${PV}/net/linx"
21
22inherit module
23
24module_do_compile_prepend () {
25 do_make_scripts
26}