summaryrefslogtreecommitdiffstats
path: root/recipes-enea/linx/linx-mod-2.6.5/linx-kernel-modules.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-enea/linx/linx-mod-2.6.5/linx-kernel-modules.patch')
-rw-r--r--recipes-enea/linx/linx-mod-2.6.5/linx-kernel-modules.patch288
1 files changed, 288 insertions, 0 deletions
diff --git a/recipes-enea/linx/linx-mod-2.6.5/linx-kernel-modules.patch b/recipes-enea/linx/linx-mod-2.6.5/linx-kernel-modules.patch
new file mode 100644
index 0000000..f29019b
--- /dev/null
+++ b/recipes-enea/linx/linx-mod-2.6.5/linx-kernel-modules.patch
@@ -0,0 +1,288 @@
1Use KERNEL_SRC and modules_install to get use of pokys build kernel modules.
2fix version.h problem.
3
4Signed-off-by: Anders Roxell <anders.roxell@enea.com>
5
6Upstream-status: Pending
7---
8diff -uNr a/cmcl/Makefile b/cmcl/Makefile
9--- a/cmcl/Makefile 2013-02-25 15:46:59.777325274 +0100
10+++ b/cmcl/Makefile 2013-02-25 15:57:22.038398316 +0100
11@@ -3,8 +3,8 @@
12 LINX ?= $(CURDIR)/../../..
13 include $(LINX)/net/linx/config.mk
14
15-KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL)/include/linux/version.h)
16-VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL)/include/linux/version.h)
17+KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
18+VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
19
20 ifneq ($(VENDOR_VERSION), "")
21 EXTRA_CFLAGS += -DGFP_IS_INT
22@@ -38,15 +38,17 @@
23
24 linx_cmcl-y += cmcl.o
25
26+SRC := $(shell pwd)
27+
28 modules:
29- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules
30+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules
31 $(CP) linx_cmcl.ko ..
32
33 clean:
34- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` clean
35+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) clean
36 $(LINXRM) Module.symvers Module.markers modules.order ../linx_cmcl.ko
37
38-install: modules
39- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules_install
40+modules_install: modules
41+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules_install
42 depmod
43
44diff -uNr a/config.mk b/config.mk
45--- a/config.mk 2013-02-25 15:46:59.781325113 +0100
46+++ b/config.mk 2013-02-25 16:13:30.672459997 +0100
47@@ -3,7 +3,7 @@
48 # CROSS_COMPILE is cross compiler prefix (including full path)
49 CROSS_COMPILE ?=
50 # KERNEL is the path to your kernel sources
51-KERNEL ?=
52+KERNEL_SRC ?=
53
54 # Host architecture
55 HOST_ARCH ?= $(patsubst i%86,i386,$(shell uname -m))
56@@ -26,13 +26,13 @@
57 endif
58
59 ifeq ($(ARCH),$(HOST_ARCH))
60-ifndef KERNEL
61-KERNEL := $(HOST_KERNEL)
62+ifndef KERNEL_SRC
63+KERNEL_SRC := $(HOST_KERNEL)
64 endif
65 else
66-ifndef KERNEL
67+ifndef KERNEL_SRC
68 ifdef NEED_KERNEL
69-$(error Please define KERNEL.)
70+$(error Please define KERNEL_SRC.)
71 endif
72 endif
73 endif
74@@ -53,8 +53,8 @@
75 ifdef CROSS_COMPILE
76 $(ECHO) "# CROSS_COMPILE=$(CROSS_COMPILE)"
77 endif
78-ifdef KERNEL
79- $(ECHO) "# KERNEL=$(KERNEL)"
80+ifdef KERNEL_SRC
81+ $(ECHO) "# KERNEL_SRC=$(KERNEL_SRC)"
82 endif
83 ifdef VERBOSE
84 $(ECHO) "# VERBOSE=$(VERBOSE)"
85@@ -62,7 +62,7 @@
86 $(ECHO) "# VERBOSE=no"
87 endif
88
89-export ARCH CROSS_COMPILE KERNEL LINX
90+export ARCH CROSS_COMPILE KERNEL_SRC LINX
91
92 .PHONY: echo_config
93
94@@ -117,5 +117,5 @@
95 # in the mercury linux distribution.
96 EXTRA_CFLAGS += -I$(KDIR)/arch/ppc -DRLNH_ALIGN_ANY
97 else # x86
98-KDIR := /lib/modules/$(shell uname -r)/build
99+KDIR := /lib/modules/$(KERNEL_VERSION)/build
100 endif
101diff -uNr a/ecm/Makefile b/ecm/Makefile
102--- a/ecm/Makefile 2013-02-25 15:46:59.781325113 +0100
103+++ b/ecm/Makefile 2013-02-25 16:11:13.754388313 +0100
104@@ -5,8 +5,8 @@
105 LINX ?= $(CURDIR)/../../..
106 include $(LINX)/net/linx/config.mk
107
108-KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL)/include/linux/version.h)
109-VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL)/include/linux/version.h)
110+KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
111+VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
112
113 ifneq ($(VENDOR_VERSION), "")
114 EXTRA_CFLAGS += -DGFP_IS_INT
115@@ -43,14 +43,16 @@
116 linx_eth_cm-y += ecm_rx.o
117 linx_eth_cm-y += ecm_kutils.o
118
119+SRC := $(shell pwd)
120+
121 modules:
122- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules
123+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules
124 $(CP) linx_eth_cm.ko ..
125
126 clean:
127- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` clean
128+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) clean
129 $(LINXRM) Module.symvers Module.markers modules.order ../linx_eth_cm.ko
130
131-install: modules
132- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules_install
133+modules_install: modules
134+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules_install
135 depmod
136diff -uNr a/Makefile b/Makefile
137--- a/Makefile 2013-02-25 15:46:59.781325113 +0100
138+++ b/Makefile 2013-02-25 15:53:22.752757899 +0100
139@@ -63,9 +63,9 @@
140 2_6_11 := 132619
141
142 # Vendors version of kernel, needed to catch certain back patches
143-VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL)/include/linux/version.h)
144+VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
145 # Main line kernel version
146-KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL)/include/linux/version.h)
147+KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
148
149 #
150 # 'gt_or_eq'
151@@ -140,14 +140,16 @@
152 obj-y += riocm/
153 obj-y += cmcl/
154
155+SRC := $(shell pwd)
156+
157 modules:
158- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules
159+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules
160 $(CP) */*.ko .
161 clean:
162- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` clean
163+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) clean
164 $(LINXRM) Module.symvers Module.markers modules.order
165
166-install: modules
167- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules_install
168+modules_install: modules
169+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules_install
170 depmod
171
172diff -uNr a/riocm/Makefile b/riocm/Makefile
173--- a/riocm/Makefile 2013-02-25 15:46:59.781325113 +0100
174+++ b/riocm/Makefile 2013-02-25 16:05:33.381125565 +0100
175@@ -5,8 +5,8 @@
176 LINX ?= $(CURDIR)/../../..
177 include $(LINX)/net/linx/config.mk
178
179-KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL)/include/linux/version.h)
180-VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL)/include/linux/version.h)
181+KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
182+VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
183
184 ifneq ($(VENDOR_VERSION), "")
185 EXTRA_CFLAGS += -DGFP_IS_INT
186@@ -43,15 +43,17 @@
187 linx_rio_cm-y += rio_rx.o
188 linx_rio_cm-y += rio_kutils.o
189
190+SRC := $(shell pwd)
191+
192 modules:
193- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules
194+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules
195 $(CP) linx_rio_cm.ko ..
196
197 clean:
198- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` clean
199+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) clean
200 $(LINXRM) Module.symvers Module.markers modules.order ../linx_rio_cm.ko
201
202-install: modules
203- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules_install
204+modules_install: modules
205+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules_install
206 depmod
207
208diff -uNr a/shmcm/Makefile b/shmcm/Makefile
209--- a/shmcm/Makefile 2013-02-25 15:46:59.781325113 +0100
210+++ b/shmcm/Makefile 2013-02-25 16:03:58.113250295 +0100
211@@ -5,8 +5,8 @@
212 LINX ?= $(CURDIR)/../../..
213 include $(LINX)/net/linx/config.mk
214
215-KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL)/include/linux/version.h)
216-VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL)/include/linux/version.h)
217+KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
218+VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
219
220 ifneq ($(VENDOR_VERSION), "")
221 EXTRA_CFLAGS += -DGFP_IS_INT
222@@ -60,7 +60,7 @@
223 -I$(LINX)/net/linx/include \
224 -I$(LINX)/net/linx/shmcm
225
226-INSTALLDIR = /lib/modules/`uname -r`/kernel/net/linx
227+INSTALLDIR = /lib/modules/$(KERNEL_VERSION)/kernel/net/linx
228 MODULES = linx_shm_cm.ko
229
230 obj-m := linx_shm_cm.o
231@@ -70,15 +70,17 @@
232 linx_shm_cm-y += shmcm_tx.o
233 linx_shm_cm-y += shmcm_kutils.o
234
235+SRC := $(shell pwd)
236+
237 modules:
238- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules
239+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules
240 $(CP) linx_shm_cm.ko ..
241
242 clean:
243- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` clean
244+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) clean
245 $(LINXRM) Module.symvers Module.markers modules.order ../linx_shm_cm.ko
246
247-install: modules
248- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules_install
249+modules_install: modules
250+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules_install
251 depmod
252
253diff -uNr a/tcp_cm/Makefile b/tcp_cm/Makefile
254--- a/tcp_cm/Makefile 2013-02-25 15:46:59.781325113 +0100
255+++ b/tcp_cm/Makefile 2013-02-25 16:10:09.097187839 +0100
256@@ -3,8 +3,8 @@
257 LINX ?= $(CURDIR)/../../..
258 include $(LINX)/net/linx/config.mk
259
260-KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL)/include/linux/version.h)
261-VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL)/include/linux/version.h)
262+KERNEL_CODE := $(shell awk '/LINUX_VERSION_CODE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
263+VENDOR_VERSION := $(shell awk '/UTS_RELEASE/ {print $$3}' $(KERNEL_SRC)/include/generated/utsrelease.h)
264
265 ifneq ($(VENDOR_VERSION), "")
266 EXTRA_CFLAGS += -DGFP_IS_INT
267@@ -38,15 +38,17 @@
268
269 linx_tcp_cm-y += tcp_cm.o
270
271+SRC := $(shell pwd)
272+
273 modules:
274- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules
275+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules
276 $(CP) linx_tcp_cm.ko ..
277
278 clean:
279- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` clean
280+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) clean
281 $(LINXRM) Module.symvers Module.markers modules.order ../linx_tcp_cm.ko
282
283-install: modules
284- $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL) M=`pwd` modules_install
285+modules_install: modules
286+ $(XMAKE) ARCH=$(ARCH) V=$(V) -C $(KERNEL_SRC) M=$(SRC) modules_install
287 depmod
288