summaryrefslogtreecommitdiffstats
path: root/recipes-core/packagegroups/packagegroup-enea-profile.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/packagegroups/packagegroup-enea-profile.bb')
-rw-r--r--recipes-core/packagegroups/packagegroup-enea-profile.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/recipes-core/packagegroups/packagegroup-enea-profile.bb b/recipes-core/packagegroups/packagegroup-enea-profile.bb
new file mode 100644
index 0000000..bc9bf43
--- /dev/null
+++ b/recipes-core/packagegroups/packagegroup-enea-profile.bb
@@ -0,0 +1,66 @@
1DESCRIPTION = "Profiling package grooup for OE-Core"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5PR = "r0"
6
7inherit pkgconfig
8
9PACKAGES = "\
10 ${PN} \
11 ${PN}-dbg \
12 ${PN}-dev \
13 "
14
15PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17ALLOW_EMPTY_${PN} = "1"
18
19
20# dany: oprofileui-server
21# lttng-viewer
22# latencytop
23# removed due to their x11 dependency.
24#
25# dany: blktrace
26# sysprof
27# removed due to their x11 dependency.
28RDEPENDS_${PN} = "\
29 oprofile \
30 ${LTTNG} \
31 "
32
33LTTNG ?= "\
34 lttng-tools \
35 lttng-modules \
36 lttng-ust \
37 "
38LTTNG_armv6 ?= ""
39
40# comment out perf since it can not been built in linux-2.6.33.9 kernel
41# perf
42
43# Will fail without a debug flavoured kernel
44# kernel-module-oprofile"
45
46# lttng-ust uses sched_getcpu() which is not there on uclibc
47# for some of the architectures it can be patched to call the
48# syscall directly but for x86_64 __NR_getcpu is a vsyscall
49# which means we can not use syscall() to call it. So we ignore
50# it for x86_64/uclibc
51
52LTTNGUST = "lttng-ust"
53LTTNGUST_libc-uclibc = ""
54
55# exmap-console
56# exmap-server
57
58# At present we only build lttng-ust on
59# qemux86/qemux86-64/qemuppc/qemuarm/emenlow/atom-pc since upstream liburcu
60# (which is required by lttng-ust) may not build on other platforms, like
61# MIPS.
62RDEPENDS_${PN}_append_qemux86 = " valgrind lttng-ust"
63RDEPENDS_${PN}_append_qemux86-64 = " ${LTTNGUST}"
64RDEPENDS_${PN}_append_qemuppc = " ${LTTNGUST}"
65RDEPENDS_${PN}_append_qemuarm = " ${LTTNGUST}"
66RDEPENDS_${PN}_append_powerpc = " ${LTTNGUST}"