summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/libuio/libuio_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/libuio/libuio_git.bb')
-rw-r--r--recipes-bsp/libuio/libuio_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/libuio/libuio_git.bb b/recipes-bsp/libuio/libuio_git.bb
new file mode 100644
index 0000000..6b004c7
--- /dev/null
+++ b/recipes-bsp/libuio/libuio_git.bb
@@ -0,0 +1,27 @@
1SUMMARY = "libUIO"
2DESCRIPTION = "Provide a generic framework for handling devices in userspace."
3HOMEPAGE = "https://www.osadl.org/UIO.uio.0.html"
4SECTION = "libs"
5LICENSE = "GPLv2"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SRCREV = "cc233857ba1613801e7218d07127d19608a99702"
10PR = "r0"
11PV = "1.0+git${SRCPV}"
12
13SRC_URI = "git://git.linutronix.de/projects/libUIO;protocol=git \
14 file://run-ptest"
15
16DEPENDS = "virtual/libc"
17
18S = "${WORKDIR}/git"
19
20inherit autotools
21
22do_install_append () {
23 if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
24 mkdir -p ${D}${PTEST_PATH}
25 install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}
26 fi
27}