summaryrefslogtreecommitdiffstats
path: root/images/enea-image-demo.bb
diff options
context:
space:
mode:
Diffstat (limited to 'images/enea-image-demo.bb')
-rw-r--r--images/enea-image-demo.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/images/enea-image-demo.bb b/images/enea-image-demo.bb
new file mode 100644
index 0000000..1f73d43
--- /dev/null
+++ b/images/enea-image-demo.bb
@@ -0,0 +1,61 @@
1# Uncomment for opkg/dpkg/rpm on available on target
2IMAGE_FSTYPES += "ext2.gz.u-boot ext3 tar.gz"
3IMAGE_FEATURES += "package-management"
4
5IMAGE_FEATURES += "eclipse-debug tools-debug tools-profile dbg-pkgs ssh-server-openssh"
6
7ENEA_GPL = " \
8 linx \
9 linx-mod"
10
11ENEA_GPL_qemux86 = ""
12ENEA_GPL_qemuppc = ""
13ENEA_GPL_armv5 = ""
14ENEA_GPL_armv7a = ""
15
16VALGRIND ?= ""
17VALGRIND_powerpc ?= "valgrind"
18VALGRIND_e500v2 ?= ""
19VALGRIND_x86 ?= "valgrind"
20VALGRIND_x86_64 ?= "valgrind"
21VALGRIND_armv7a ?= "valgrind"
22
23IMAGE_INSTALL = " \
24 packagegroup-enea-core-boot \
25 packagegroup-enea-debug \
26 packagegroup-enea-profile \
27 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
28 kexec-tools \
29 openssl \
30 bc \
31 dhcp-client \
32 sqlite3 \
33 pramfs-init \
34 zip \
35 gettext \
36 gettext-runtime \
37 mtd-utils \
38 net-tools \
39 pciutils \
40 ltp \
41 libuio \
42 usbutils \
43 lttng-tools \
44 lttng-modules \
45 babeltrace \
46 netbase \
47 sudo \
48 ${ENEA_GPL} \
49 ${VALGRIND} \
50 "
51
52IMAGE_INSTALL += "kernel-modules "
53
54IMAGE_LINGUAS = ""
55
56inherit core-image
57inherit image_types_uboot
58
59IMAGE_ROOTFS_SIZE = "1"
60# Increased the overhead factor to be able to build via nfs.
61IMAGE_OVERHEAD_FACTOR = "2"