summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/files/net-CVE-2015-2041.patch62
-rw-r--r--recipes-kernel/linux/linux-yocto_3.14.bbappend1
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/net-CVE-2015-2041.patch b/recipes-kernel/linux/files/net-CVE-2015-2041.patch
new file mode 100644
index 0000000..e0754cd
--- /dev/null
+++ b/recipes-kernel/linux/files/net-CVE-2015-2041.patch
@@ -0,0 +1,62 @@
1From ecca64226ce2960280921e09ae33e90f82b5c408 Mon Sep 17 00:00:00 2001
2From: Sasha Levin <sasha.levin@oracle.com>
3Date: Fri, 23 Jan 2015 20:47:00 -0500
4Subject: [PATCH] net: llc: use correct size for sysctl timeout entries
5
6commit 6b8d9117ccb4f81b1244aafa7bc70ef8fa45fc49 upstream.
7
8The timeout entries are sizeof(int) rather than sizeof(long), which
9means that when they were getting read we'd also leak kernel memory
10to userspace along with the timeout values.
11
12Fixes CVE-2015-2041
13Upstream-Status: Backport
14
15Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
16Signed-off-by: David S. Miller <davem@davemloft.net>
17Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
18Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
19---
20 net/llc/sysctl_net_llc.c | 8 ++++----
21 1 file changed, 4 insertions(+), 4 deletions(-)
22
23diff --git a/net/llc/sysctl_net_llc.c b/net/llc/sysctl_net_llc.c
24index 612a5dd..799bafc 100644
25--- a/net/llc/sysctl_net_llc.c
26+++ b/net/llc/sysctl_net_llc.c
27@@ -18,28 +18,28 @@ static struct ctl_table llc2_timeout_table[] = {
28 {
29 .procname = "ack",
30 .data = &sysctl_llc2_ack_timeout,
31- .maxlen = sizeof(long),
32+ .maxlen = sizeof(sysctl_llc2_ack_timeout),
33 .mode = 0644,
34 .proc_handler = proc_dointvec_jiffies,
35 },
36 {
37 .procname = "busy",
38 .data = &sysctl_llc2_busy_timeout,
39- .maxlen = sizeof(long),
40+ .maxlen = sizeof(sysctl_llc2_busy_timeout),
41 .mode = 0644,
42 .proc_handler = proc_dointvec_jiffies,
43 },
44 {
45 .procname = "p",
46 .data = &sysctl_llc2_p_timeout,
47- .maxlen = sizeof(long),
48+ .maxlen = sizeof(sysctl_llc2_p_timeout),
49 .mode = 0644,
50 .proc_handler = proc_dointvec_jiffies,
51 },
52 {
53 .procname = "rej",
54 .data = &sysctl_llc2_rej_timeout,
55- .maxlen = sizeof(long),
56+ .maxlen = sizeof(sysctl_llc2_rej_timeout),
57 .mode = 0644,
58 .proc_handler = proc_dointvec_jiffies,
59 },
60--
611.9.1
62
diff --git a/recipes-kernel/linux/linux-yocto_3.14.bbappend b/recipes-kernel/linux/linux-yocto_3.14.bbappend
index bab3136..5b7cdf3 100644
--- a/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -3,4 +3,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3SRC_URI += "file://HID_CVE_patches/0005-HID-steelseries-validate-output-report-details.patch \ 3SRC_URI += "file://HID_CVE_patches/0005-HID-steelseries-validate-output-report-details.patch \
4 file://keys-CVE-2015-1333.patch \ 4 file://keys-CVE-2015-1333.patch \
5 file://udp_fix_behavior_of_wrong_checksums.patch \ 5 file://udp_fix_behavior_of_wrong_checksums.patch \
6 file://net-CVE-2015-2041.patch \
6 " 7 "