summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSona Sarmadi <sona.sarmadi@enea.com>2016-04-14 14:40:16 +0200
committerTudor Florea <tudor.florea@enea.com>2016-04-15 18:27:08 +0200
commit735bb1170100e71eed6c54a8c2c87942df01f864 (patch)
treefaa2695d1194f6dee944a824c0e8b0be52db16c9
parentc3127da4e79258a68d5b9c6d1fbfb5f2e5e97fcb (diff)
downloadmeta-enea-735bb1170100e71eed6c54a8c2c87942df01f864.tar.gz
kernel-ALSA: CVE-2016-2384
Fixes double-free in usb-audio triggered by invalid USB descriptor (in the linux-yocto-3.14). Reference: https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-2384 Reference to the upstream patch: https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/ patch/?id=05dd81eafd796a5f1db09cc9fe2bff44cfd56dfe Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Tudor Florea <tudor.florea@enea.com>
-rw-r--r--recipes-kernel/linux/linux-yocto-3.14/ALSA-CVE-2016-2384.patch40
-rw-r--r--recipes-kernel/linux/linux-yocto_3.14.bbappend1
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto-3.14/ALSA-CVE-2016-2384.patch b/recipes-kernel/linux/linux-yocto-3.14/ALSA-CVE-2016-2384.patch
new file mode 100644
index 0000000..5846c4f
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto-3.14/ALSA-CVE-2016-2384.patch
@@ -0,0 +1,40 @@
1From 05dd81eafd796a5f1db09cc9fe2bff44cfd56dfe Mon Sep 17 00:00:00 2001
2From: Andrey Konovalov <andreyknvl@gmail.com>
3Date: Sat, 13 Feb 2016 11:08:06 +0300
4Subject: ALSA: usb-audio: avoid freeing umidi object twice
5
6commit 07d86ca93db7e5cdf4743564d98292042ec21af7 upstream.
7
8The 'umidi' object will be free'd on the error path by snd_usbmidi_free()
9when tearing down the rawmidi interface. So we shouldn't try to free it
10in snd_usbmidi_create() after having registered the rawmidi interface.
11
12Found by KASAN.
13
14CVE: CVE-2016-2384
15Upstream-Status: Backport
16
17Signed-off-by: Andrey Konovalov <andreyknvl@gmail.com>
18Acked-by: Clemens Ladisch <clemens@ladisch.de>
19Signed-off-by: Takashi Iwai <tiwai@suse.de>
20Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
21Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
22---
23 sound/usb/midi.c | 1 -
24 1 file changed, 1 deletion(-)
25
26diff --git a/sound/usb/midi.c b/sound/usb/midi.c
27index 9123fc5..424c1e8 100644
28--- a/sound/usb/midi.c
29+++ b/sound/usb/midi.c
30@@ -2365,7 +2365,6 @@ int snd_usbmidi_create(struct snd_card *card,
31 else
32 err = snd_usbmidi_create_endpoints(umidi, endpoints);
33 if (err < 0) {
34- snd_usbmidi_free(umidi);
35 return err;
36 }
37
38--
39cgit v0.12
40
diff --git a/recipes-kernel/linux/linux-yocto_3.14.bbappend b/recipes-kernel/linux/linux-yocto_3.14.bbappend
index 54a092d..bc3a24f 100644
--- a/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -27,4 +27,5 @@ SRC_URI += "file://HID_CVE_patches/0005-HID-steelseries-validate-output-report-d
27 file://ipc-CVE-2015-7613.patch \ 27 file://ipc-CVE-2015-7613.patch \
28 file://net-unix-CVE-2013-7446.patch \ 28 file://net-unix-CVE-2013-7446.patch \
29 file://ALSA-CVE-2016-2546.patch \ 29 file://ALSA-CVE-2016-2546.patch \
30 file://ALSA-CVE-2016-2384.patch \
30 " 31 "