summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-03-30 16:45:16 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2016-03-30 16:46:02 +0200
commitb9ca1a2a5f1dd0a19d9acef95621e5ae902a8b4f (patch)
tree49bae198a746ad08c1ce3a562c89fc0e80788d74
downloadmeta-enea-networking-b9ca1a2a5f1dd0a19d9acef95621e5ae902a8b4f.tar.gz
initial commit
Create layer Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--COPYING.MIT17
-rw-r--r--README62
-rw-r--r--conf/layer.conf13
3 files changed, 92 insertions, 0 deletions
diff --git a/COPYING.MIT b/COPYING.MIT
new file mode 100644
index 0000000..89de354
--- /dev/null
+++ b/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/README b/README
new file mode 100644
index 0000000..1ed1782
--- /dev/null
+++ b/README
@@ -0,0 +1,62 @@
1meta-enea-networking
2===================================================================
3
4This layer is contains Enea customizations for the Networking profile.
5
6Dependencies
7============
8
9This layer depends on:
10
11 URI: git://git.enea.com/linux/meta-enea-base
12 branch: master
13 revision: HEAD
14
15 URI: git://git.yoctoproject.org/meta-fsl-ppc
16 branch: master
17 revision: HEAD
18
19Source code
20===========
21
22git://git.enea.com/linux/meta-enea-networking.git
23
24
25Patches
26=======
27
28Please submit any patches against the enea-networking layer to the
29linux-maintainers mailing list: linux-maintainers@enea.com
30
31Maintainers: Enea Linux Team <linux-maintainers@enea.com>
32
33
34Table
35=================
36
37 I. Adding the enea-networking layer to your build
38 II. Misc
39
40
41I. Adding the enea-networking layer to your build
42=================================================
43
44In order to use this layer, you need to make the build system aware of
45it.
46
47Assuming the enea-networking layer exists at the top-level of your
48yocto build tree, you can add it to the build system by adding the
49location of the enea-networking layer to bblayers.conf, along with any
50other layers needed. e.g.:
51
52
53 BBLAYERS ?= " \
54 /path/to/yocto/meta \
55 /path/to/yocto/meta-poky \
56 /path/to/yocto/meta-enea-base \
57 /path/to/yocto/meta-fsl-ppc \
58 /path/to/yocto/meta-enea-networking \
59 "
60
61II. Misc
62========
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..080fea2
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,13 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/images/* \
7 ${LAYERDIR}/packagegroups/* \
8 ${LAYERDIR}/recipes-*/*/*.bbappend"
9
10BBFILE_COLLECTIONS += "enea-networking"
11BBFILE_PATTERN_enea-networking = "^${LAYERDIR}/"
12BBFILE_PRIORITY_enea-networking = "7"
13LAYERDEPENDS_enea-networking = "enea-base fsl-ppc"