summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Calianu <adrian.calianu@enea.com>2016-05-30 12:09:31 +0200
committerMartin Borg <martin.borg@enea.com>2016-05-31 14:11:55 +0200
commit961e43f93180fc36dc700e41191ca2fc5103342f (patch)
treeeffb9e39f3a78c4f61ed7c2f12b38aa2d6bede78
parent752ec549839bc34ad833bc29a91dc7e0bb42bb15 (diff)
downloadmeta-enea-networking-961e43f93180fc36dc700e41191ca2fc5103342f.tar.gz
busybox: enable networking tools
Few more networking tools enabled for networking profile arp, netstat, traceroute Signed-off-by: Adrian Calianu <adrian.calianu@enea.com> Signed-off-by: Martin Borg <martin.borg@enea.com>
-rw-r--r--recipes-core/busybox/busybox/arp.cfg2
-rw-r--r--recipes-core/busybox/busybox/ip_extra.cfg11
-rw-r--r--recipes-core/busybox/busybox/nc_extra.cfg3
-rw-r--r--recipes-core/busybox/busybox/netstat_extra.cfg2
-rw-r--r--recipes-core/busybox/busybox/traceroute.cfg2
-rw-r--r--recipes-core/busybox/busybox_%.bbappend9
6 files changed, 29 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox/arp.cfg b/recipes-core/busybox/busybox/arp.cfg
new file mode 100644
index 0000000..d42f23e
--- /dev/null
+++ b/recipes-core/busybox/busybox/arp.cfg
@@ -0,0 +1,2 @@
1CONFIG_ARP=y
2CONFIG_ARPING=y
diff --git a/recipes-core/busybox/busybox/ip_extra.cfg b/recipes-core/busybox/busybox/ip_extra.cfg
new file mode 100644
index 0000000..4e16954
--- /dev/null
+++ b/recipes-core/busybox/busybox/ip_extra.cfg
@@ -0,0 +1,11 @@
1
2CONFIG_FEATURE_IFCONFIG_SLIP=y
3CONFIG_FEATURE_IFCONFIG_MEMSTART_IOADDR_IRQ=y
4CONFIG_FEATURE_IP_RULE=y
5CONFIG_FEATURE_IP_SHORT_FORMS=y
6CONFIG_FEATURE_IP_RARE_PROTOCOLS=y
7CONFIG_IPADDR=y
8CONFIG_IPLINK=y
9CONFIG_IPROUTE=y
10CONFIG_IPTUNNEL=y
11CONFIG_IPRULE=y
diff --git a/recipes-core/busybox/busybox/nc_extra.cfg b/recipes-core/busybox/busybox/nc_extra.cfg
new file mode 100644
index 0000000..4e049e8
--- /dev/null
+++ b/recipes-core/busybox/busybox/nc_extra.cfg
@@ -0,0 +1,3 @@
1CONFIG_NC_SERVER=y
2CONFIG_NC_EXTRA=y
3CONFIG_NC_110_COMPAT=y
diff --git a/recipes-core/busybox/busybox/netstat_extra.cfg b/recipes-core/busybox/busybox/netstat_extra.cfg
new file mode 100644
index 0000000..1182b94
--- /dev/null
+++ b/recipes-core/busybox/busybox/netstat_extra.cfg
@@ -0,0 +1,2 @@
1CONFIG_FEATURE_NETSTAT_WIDE=y
2CONFIG_FEATURE_NETSTAT_PRG=y
diff --git a/recipes-core/busybox/busybox/traceroute.cfg b/recipes-core/busybox/busybox/traceroute.cfg
new file mode 100644
index 0000000..385a1e2
--- /dev/null
+++ b/recipes-core/busybox/busybox/traceroute.cfg
@@ -0,0 +1,2 @@
1CONFIG_TRACEROUTE6=y
2CONFIG_FEATURE_TRACEROUTE_VERBOSE=y
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend
new file mode 100644
index 0000000..b7de6ac
--- /dev/null
+++ b/recipes-core/busybox/busybox_%.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " \
4 file://arp.cfg \
5 file://ip_extra.cfg \
6 file://nc_extra.cfg \
7 file://netstat_extra.cfg \
8 file://traceroute.cfg \
9 "