summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-04-04 14:58:05 +0200
committerMartin Borg <martin.borg@enea.com>2016-04-13 14:44:51 +0200
commita3838f854fd689b8c695a0e24485ac19695ce47d (patch)
tree3d200719216b1c4dc30238dbcd22397bba4e8a7e
parentabe0b654b7e4d7bbe2b42468c28baa73e0f05882 (diff)
downloadmeta-enea-networking-a3838f854fd689b8c695a0e24485ac19695ce47d.tar.gz
Add enea-networking packagegroups
These packagegroups are specific to the EL Networking profile. packagegroup-enea-networking-usdpaa will contain recipes needed by USDPAA in the EL networking profile packagegroup-enea-networking will contain all recipes specific to the EL Networking profile, inlcuding the usdpaa packagegroup Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Martin Borg <martin.borg@enea.com>
-rw-r--r--packagegroups/packagegroup-enea-networking-usdpaa.bb22
-rw-r--r--packagegroups/packagegroup-enea-networking.bb16
2 files changed, 38 insertions, 0 deletions
diff --git a/packagegroups/packagegroup-enea-networking-usdpaa.bb b/packagegroups/packagegroup-enea-networking-usdpaa.bb
new file mode 100644
index 0000000..3c03817
--- /dev/null
+++ b/packagegroups/packagegroup-enea-networking-usdpaa.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Packages needed for Freescale USDPAA support"
2DESCRIPTION = "This package group includes userspace packages required by USDPAA."
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
6
7inherit packagegroup
8
9USDPAA_PKGS = " \
10 eth-config \
11 flib \
12 fmc \
13 fmlib \
14 usdpaa \
15 "
16
17PACKAGES = "${PN}"
18
19RDEPENDS_${PN} = " ${USDPAA_PKGS} \
20 "
21
22RRECOMMENDS_${PN} = ""
diff --git a/packagegroups/packagegroup-enea-networking.bb b/packagegroups/packagegroup-enea-networking.bb
new file mode 100644
index 0000000..c7a31a7
--- /dev/null
+++ b/packagegroups/packagegroup-enea-networking.bb
@@ -0,0 +1,16 @@
1SUMMARY = "Packages specific to the Enea Linux Networking Profile"
2DESCRIPTION = "This package group includes packages and packagegroups required for the Enea Linux \
3 Networking Profile."
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
7
8
9inherit packagegroup
10
11PACKAGES = "${PN}"
12
13RDEPENDS_${PN} = " packagegroup-enea-networking-usdpaa \
14 "
15
16RRECOMMENDS_${PN} = ""