summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf3
-rw-r--r--conf/machine/inteld1521.conf4
-rw-r--r--conf/machine/qemux86-64-corei7.conf34
-rw-r--r--recipes-kernel/linux/linux-intel-guest_4.9.bb (renamed from recipes-kernel/linux/linux-intel_4.9.bbappend)0
-rw-r--r--recipes-kernel/linux/linux-intel-host_4.9.bb1
-rw-r--r--recipes-kernel/linux/linux-intel-sdk_4.9.bb1
-rw-r--r--recipes-kernel/linux/linux-intel.inc3
-rw-r--r--recipes-kernel/linux/linux-yocto_4.9.bbappend16
8 files changed, 42 insertions, 20 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 3da3779..44a788c 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -10,3 +10,6 @@ BBFILE_COLLECTIONS += "enea-bsp-x86"
10BBFILE_PATTERN_enea-bsp-x86 = "^${LAYERDIR}/" 10BBFILE_PATTERN_enea-bsp-x86 = "^${LAYERDIR}/"
11BBFILE_PRIORITY_enea-bsp-x86 = "6" 11BBFILE_PRIORITY_enea-bsp-x86 = "6"
12LAYERDEPENDS_enea-bsp-x86 = "intel" 12LAYERDEPENDS_enea-bsp-x86 = "intel"
13
14# change qemux86-64 arch from core2 to corei7
15require conf/machine/qemux86-64-corei7.conf
diff --git a/conf/machine/inteld1521.conf b/conf/machine/inteld1521.conf
index 091ef18..d1c9104 100644
--- a/conf/machine/inteld1521.conf
+++ b/conf/machine/inteld1521.conf
@@ -7,8 +7,8 @@
7# If the configuration need to be updated please check first the original .conf 7# If the configuration need to be updated please check first the original .conf
8 8
9# Soft set linux-yocto as preferred kernel like x86-base.inc 9# Soft set linux-yocto as preferred kernel like x86-base.inc
10PREFERRED_PROVIDER_virtual/kernel ?= "linux-intel" 10PREFERRED_PROVIDER_virtual/kernel ?= "linux-intel-host"
11PREFERRED_PROVIDER_virtual/kernel_poky-tiny ?= "linux-intel" 11PREFERRED_PROVIDER_virtual/kernel_poky-tiny ?= "linux-intel-host"
12PREFERRED_VERSION_linux-intel ?= "4.9%" 12PREFERRED_VERSION_linux-intel ?= "4.9%"
13 13
14# include the user space intel microcode loading support in the generated images. 14# include the user space intel microcode loading support in the generated images.
diff --git a/conf/machine/qemux86-64-corei7.conf b/conf/machine/qemux86-64-corei7.conf
new file mode 100644
index 0000000..8f4bc1f
--- /dev/null
+++ b/conf/machine/qemux86-64-corei7.conf
@@ -0,0 +1,34 @@
1PREFERRED_PROVIDER_virtual/kernel_qemux86-64 = "linux-intel-guest"
2
3DEFAULTTUNE_qemux86-64 = "corei7-64"
4
5# Following is the content of "conf/machine/include/tune-corei7.inc"
6# without core2 inheritance which is already done in qemux86-64.
7# We cannot inherite it here due to "duplicate included" warnings and
8# other errors induced by that inclusion
9
10# Extra tune features
11TUNEVALID[corei7] = "Enable corei7 specific processor optimizations"
12TUNE_CCARGS .= "${@bb.utils.contains('TUNE_FEATURES', 'corei7', ' -march=corei7 -mtune=corei7 -mfpmath=sse -msse4.2', '', d)}"
13
14# Extra tune selections
15AVAILTUNES += "corei7-32"
16TUNE_FEATURES_tune-corei7-32 = "${TUNE_FEATURES_tune-x86} corei7"
17BASE_LIB_tune-corei7-32 = "lib"
18TUNE_PKGARCH_tune-corei7-32 = "corei7-32"
19PACKAGE_EXTRA_ARCHS_tune-corei7-32 = "${PACKAGE_EXTRA_ARCHS_tune-core2-32} corei7-32"
20QEMU_EXTRAOPTIONS_corei7-32 = " -cpu Nehalem,check=false"
21
22AVAILTUNES += "corei7-64"
23TUNE_FEATURES_tune-corei7-64 = "${TUNE_FEATURES_tune-x86-64} corei7"
24BASE_LIB_tune-corei7-64 = "lib64"
25TUNE_PKGARCH_tune-corei7-64 = "corei7-64"
26PACKAGE_EXTRA_ARCHS_tune-corei7-64 = "${PACKAGE_EXTRA_ARCHS_tune-core2-64} corei7-64"
27QEMU_EXTRAOPTIONS_corei7-64 = " -cpu Nehalem,check=false"
28
29AVAILTUNES += "corei7-64-x32"
30TUNE_FEATURES_tune-corei7-64-x32 = "${TUNE_FEATURES_tune-x86-64-x32} corei7"
31BASE_LIB_tune-corei7-64-x32 = "libx32"
32TUNE_PKGARCH_tune-corei7-64-x32 = "corei7-64-x32"
33PACKAGE_EXTRA_ARCHS_tune-corei7-64-x32 = "${PACKAGE_EXTRA_ARCHS_tune-core2-64-x32} corei7-64-x32"
34QEMU_EXTRAOPTIONS_corei7-64-x32 = " -cpu Nehalem,check=false"
diff --git a/recipes-kernel/linux/linux-intel_4.9.bbappend b/recipes-kernel/linux/linux-intel-guest_4.9.bb
index 6be0508..6be0508 100644
--- a/recipes-kernel/linux/linux-intel_4.9.bbappend
+++ b/recipes-kernel/linux/linux-intel-guest_4.9.bb
diff --git a/recipes-kernel/linux/linux-intel-host_4.9.bb b/recipes-kernel/linux/linux-intel-host_4.9.bb
new file mode 100644
index 0000000..6be0508
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-host_4.9.bb
@@ -0,0 +1 @@
require linux-intel.inc
diff --git a/recipes-kernel/linux/linux-intel-sdk_4.9.bb b/recipes-kernel/linux/linux-intel-sdk_4.9.bb
index 913421a..71417af 100644
--- a/recipes-kernel/linux/linux-intel-sdk_4.9.bb
+++ b/recipes-kernel/linux/linux-intel-sdk_4.9.bb
@@ -1,4 +1,3 @@
1require common/recipes-kernel/linux/linux-intel_4.9.bb
2require linux-intel.inc 1require linux-intel.inc
3 2
4# Debug tools support 3# Debug tools support
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index ec91f34..733a329 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -1,6 +1,7 @@
1require common/recipes-kernel/linux/linux-intel_4.9.bb
1require recipes-kernel/linux/linux-deploy-kconfig.inc 2require recipes-kernel/linux/linux-deploy-kconfig.inc
2 3
3SRCREV_metaenea ?= "28da254d1c5ae012a6e064671aa14850c2a21a25" 4SRCREV_metaenea = "7579efbdb49529f36652b69d4630c6c43907f77b"
4KENEABRANCH = "intel-4.9" 5KENEABRANCH = "intel-4.9"
5SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta" 6SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta"
6 7
diff --git a/recipes-kernel/linux/linux-yocto_4.9.bbappend b/recipes-kernel/linux/linux-yocto_4.9.bbappend
deleted file mode 100644
index 41e94c8..0000000
--- a/recipes-kernel/linux/linux-yocto_4.9.bbappend
+++ /dev/null
@@ -1,16 +0,0 @@
1require recipes-kernel/linux/linux-deploy-kconfig.inc
2
3SRCREV_metaenea ?= "5057d9d3837fc35814a402b9c0384a064d260d05"
4KENEABRANCH = "yocto-4.9"
5SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta"
6
7KERNEL_FEATURES_append = " features/udev/udev.scc"
8
9# NFS boot support
10KERNEL_FEATURES_append = " features/blkdev/net_blk_dev.scc"
11
12# Virtual function support
13KERNEL_FEATURES_append = " features/ixgbevf/ixgbevf_y.scc"
14
15#IPv4 waiting for carrier on
16KERNEL_FEATURES_append = " patches/ipv4/ipv4wait.scc"