summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-sdk_4.9.bb
diff options
context:
space:
mode:
authorDragos Motrea <Dragos.Motrea@enea.com>2017-05-16 14:36:21 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2017-05-18 10:08:11 +0200
commit51ac95860610632c3d76306eec3c282c407c9d74 (patch)
tree8fdbb2c8c8e6c59f838f8925ff0e34fe1a020078 /recipes-kernel/linux/linux-intel-sdk_4.9.bb
parent4dbc08f79d89ddce9e872f89ba3bbf8d382443bc (diff)
downloadmeta-enea-bsp-x86-51ac95860610632c3d76306eec3c282c407c9d74.tar.gz
Added debug tools support to intel-sdk kernel
Support for the following debug tools was added to intel-sdk kernel: kgdb/gdb, perf, latencytop, systemtap, oprofile, lttng. Signed-off-by: Dragos Motrea <Dragos.Motrea@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-kernel/linux/linux-intel-sdk_4.9.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-sdk_4.9.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-sdk_4.9.bb b/recipes-kernel/linux/linux-intel-sdk_4.9.bb
index 79b612f..913421a 100644
--- a/recipes-kernel/linux/linux-intel-sdk_4.9.bb
+++ b/recipes-kernel/linux/linux-intel-sdk_4.9.bb
@@ -1,2 +1,11 @@
1require common/recipes-kernel/linux/linux-intel_4.9.bb 1require common/recipes-kernel/linux/linux-intel_4.9.bb
2require linux-intel.inc 2require linux-intel.inc
3
4# Debug tools support
5KERNEL_FEATURES_append = " features/debug/debug_kernel_y.scc"
6KERNEL_FEATURES_append = " features/kgdb/kgdb_y.scc"
7KERNEL_FEATURES_append = " features/lttng/lttng_y.scc"
8KERNEL_FEATURES_append = " features/latencytop/latencytop_y.scc"
9KERNEL_FEATURES_append = " features/perf/perf_y.scc"
10KERNEL_FEATURES_append = " features/systemtap/systemtap_y.scc"
11KERNEL_FEATURES_append = " features/oprofile/oprofile_y.scc"