summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_17.02.bbappend
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2017-03-07 13:59:26 +0100
committerMartin Borg <martin.borg@enea.com>2017-03-07 14:09:06 +0100
commit74ab50711bfcfa7947709f8ee3db9a193ff5aa06 (patch)
tree0550db1a10253e08f0a0533251591fd5054f7686 /recipes-extended/dpdk/dpdk_17.02.bbappend
parent20e9d6c1d3c10a2bce50c481c83e1e0ab11e13ef (diff)
downloadmeta-enea-bsp-x86-74ab50711bfcfa7947709f8ee3db9a193ff5aa06.tar.gz
Uprev the dpdk append
To keep in synch with meta-intel Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Martin Borg <martin.borg@enea.com>
Diffstat (limited to 'recipes-extended/dpdk/dpdk_17.02.bbappend')
-rw-r--r--recipes-extended/dpdk/dpdk_17.02.bbappend27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_17.02.bbappend b/recipes-extended/dpdk/dpdk_17.02.bbappend
new file mode 100644
index 0000000..ca155d0
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_17.02.bbappend
@@ -0,0 +1,27 @@
1COMPATIBLE_MACHINE_inteld1521 = "inteld1521"
2COMPATIBLE_MACHINE_qemux86-64 = "qemux86-64"
3
4# lspci - required by dpdk tools/scripts
5RDEPENDS_${PN} += "pciutils"
6
7export RTE_TARGET="${@bb.utils.contains("TUNE_FEATURES", "m64", "x86_64-native-linuxapp-gcc", "i686-native-linuxapp-gcc", d)}"
8export ETHTOOL_LIB_PATH = "${S}/examples/ethtool/lib/${RTE_TARGET}/lib/"
9
10# Overrides the default value set to DPDK_TARGET_MACH in dpdk.inc,
11# with the purpose adding 'inteld1521' to 'multiarch_options'
12export DPDK_TARGET_MACH = "${@get_dpdk_target(bb,d)}"
13
14def get_dpdk_target(bb, d):
15 target_arch = d.getVar('MACHINE_ARCH', True)
16 multiarch_options = {
17 "mohonpeak64":"atm",
18 "mohonpeak32":"atm",
19 "crystalforest": "ivb",
20 "intel_corei7_64": "hsw",
21 "inteld1521": "hsw",
22 "qemux86_64": "default",
23 }
24
25 if target_arch in multiarch_options :
26 return multiarch_options[target_arch]
27 return ""