summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDragos Motrea <Dragos.Motrea@enea.com>2017-06-20 10:02:41 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2017-06-20 10:24:46 +0200
commite48207d22d54ab29cbe11859454a2bd335382ce4 (patch)
tree46ead2bbb089cd01b117ead0fd3a64b9503bb29b
parent339c9ce135de771df7b106d2f7ef7959f2afc458 (diff)
downloadmeta-enea-bsp-x86-e48207d22d54ab29cbe11859454a2bd335382ce4.tar.gz
kernel: Add kernel config file to deploy directory
Signed-off-by: Dragos Motrea <Dragos.Motrea@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-kernel/linux/linux-common.inc14
-rw-r--r--recipes-kernel/linux/linux-intel.inc2
-rw-r--r--recipes-kernel/linux/linux-yocto_4.9.bbappend2
3 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-common.inc b/recipes-kernel/linux/linux-common.inc
new file mode 100644
index 0000000..426b0ff
--- /dev/null
+++ b/recipes-kernel/linux/linux-common.inc
@@ -0,0 +1,14 @@
1kernel_do_deploy[vardepsexclude] = "DATETIME"
2kernel_do_deploy_append () {
3
4 #
5 # Drop the regular defconfig along side the others for consistency
6 #
7 cp ${B}/.config ${DEPLOYDIR}/config-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}.config
8
9 #
10 # add symlink
11 #
12 ln -sf config-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}.config ${DEPLOYDIR}/config-${MACHINE}.config
13
14}
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index 49a1ba1..d9f563c 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -1,3 +1,5 @@
1require linux-common.inc
2
1SRCREV_metaenea ?= "28da254d1c5ae012a6e064671aa14850c2a21a25" 3SRCREV_metaenea ?= "28da254d1c5ae012a6e064671aa14850c2a21a25"
2KENEABRANCH = "intel-4.9" 4KENEABRANCH = "intel-4.9"
3SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta" 5SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta"
diff --git a/recipes-kernel/linux/linux-yocto_4.9.bbappend b/recipes-kernel/linux/linux-yocto_4.9.bbappend
index 8883c10..42ba9f1 100644
--- a/recipes-kernel/linux/linux-yocto_4.9.bbappend
+++ b/recipes-kernel/linux/linux-yocto_4.9.bbappend
@@ -1,3 +1,5 @@
1require linux-common.inc
2
1SRCREV_metaenea ?= "5057d9d3837fc35814a402b9c0384a064d260d05" 3SRCREV_metaenea ?= "5057d9d3837fc35814a402b9c0384a064d260d05"
2KENEABRANCH = "yocto-4.9" 4KENEABRANCH = "yocto-4.9"
3SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta" 5SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta"