summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Borg <martin.borg@enea.com>2017-08-24 15:49:56 +0200
committerMartin Borg <martin.borg@enea.com>2017-08-24 15:50:37 +0200
commit6d88d7a31b77a965552e33e62cec1598e05dc205 (patch)
tree90c541ff301e804ca09fc7810356e354b401a635
parenta82616a1d95bcc6bbac036570d2b61b90b0a9d63 (diff)
parent7a572a7ca2299f67237f870007fe4e547468c3fe (diff)
downloadmeta-enea-bsp-x86-6d88d7a31b77a965552e33e62cec1598e05dc205.tar.gz
Merge branch 'octeontx-bsp' into pyro
Signed-off-by: Martin Borg <martin.borg@enea.com>
-rw-r--r--recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bbappend2
-rw-r--r--recipes-extended/dpdk/dpdk_17.02.bbappend27
-rw-r--r--recipes-kernel/linux/linux-common.inc14
-rw-r--r--recipes-kernel/linux/linux-intel.inc2
-rw-r--r--recipes-kernel/linux/linux-yocto_4.9.bbappend2
5 files changed, 2 insertions, 45 deletions
diff --git a/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bbappend b/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bbappend
deleted file mode 100644
index 9963b86..0000000
--- a/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
1COMPATIBLE_MACHINE_inteld1521 = "inteld1521"
2COMPATIBLE_MACHINE_qemux86-64 = "qemux86-64"
diff --git a/recipes-extended/dpdk/dpdk_17.02.bbappend b/recipes-extended/dpdk/dpdk_17.02.bbappend
deleted file mode 100644
index ca155d0..0000000
--- a/recipes-extended/dpdk/dpdk_17.02.bbappend
+++ /dev/null
@@ -1,27 +0,0 @@
1COMPATIBLE_MACHINE_inteld1521 = "inteld1521"
2COMPATIBLE_MACHINE_qemux86-64 = "qemux86-64"
3
4# lspci - required by dpdk tools/scripts
5RDEPENDS_${PN} += "pciutils"
6
7export RTE_TARGET="${@bb.utils.contains("TUNE_FEATURES", "m64", "x86_64-native-linuxapp-gcc", "i686-native-linuxapp-gcc", d)}"
8export ETHTOOL_LIB_PATH = "${S}/examples/ethtool/lib/${RTE_TARGET}/lib/"
9
10# Overrides the default value set to DPDK_TARGET_MACH in dpdk.inc,
11# with the purpose adding 'inteld1521' to 'multiarch_options'
12export DPDK_TARGET_MACH = "${@get_dpdk_target(bb,d)}"
13
14def get_dpdk_target(bb, d):
15 target_arch = d.getVar('MACHINE_ARCH', True)
16 multiarch_options = {
17 "mohonpeak64":"atm",
18 "mohonpeak32":"atm",
19 "crystalforest": "ivb",
20 "intel_corei7_64": "hsw",
21 "inteld1521": "hsw",
22 "qemux86_64": "default",
23 }
24
25 if target_arch in multiarch_options :
26 return multiarch_options[target_arch]
27 return ""
diff --git a/recipes-kernel/linux/linux-common.inc b/recipes-kernel/linux/linux-common.inc
deleted file mode 100644
index 426b0ff..0000000
--- a/recipes-kernel/linux/linux-common.inc
+++ /dev/null
@@ -1,14 +0,0 @@
1kernel_do_deploy[vardepsexclude] = "DATETIME"
2kernel_do_deploy_append () {
3
4 #
5 # Drop the regular defconfig along side the others for consistency
6 #
7 cp ${B}/.config ${DEPLOYDIR}/config-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}.config
8
9 #
10 # add symlink
11 #
12 ln -sf config-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}.config ${DEPLOYDIR}/config-${MACHINE}.config
13
14}
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index d9f563c..ec91f34 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -1,4 +1,4 @@
1require linux-common.inc 1require recipes-kernel/linux/linux-deploy-kconfig.inc
2 2
3SRCREV_metaenea ?= "28da254d1c5ae012a6e064671aa14850c2a21a25" 3SRCREV_metaenea ?= "28da254d1c5ae012a6e064671aa14850c2a21a25"
4KENEABRANCH = "intel-4.9" 4KENEABRANCH = "intel-4.9"
diff --git a/recipes-kernel/linux/linux-yocto_4.9.bbappend b/recipes-kernel/linux/linux-yocto_4.9.bbappend
index 42ba9f1..41e94c8 100644
--- a/recipes-kernel/linux/linux-yocto_4.9.bbappend
+++ b/recipes-kernel/linux/linux-yocto_4.9.bbappend
@@ -1,4 +1,4 @@
1require linux-common.inc 1require recipes-kernel/linux/linux-deploy-kconfig.inc
2 2
3SRCREV_metaenea ?= "5057d9d3837fc35814a402b9c0384a064d260d05" 3SRCREV_metaenea ?= "5057d9d3837fc35814a402b9c0384a064d260d05"
4KENEABRANCH = "yocto-4.9" 4KENEABRANCH = "yocto-4.9"