summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSona Sarmadi <sona.sarmadi@enea.com>2018-09-21 08:34:53 +0200
committerMartin Borg <martin.borg@enea.com>2018-09-26 11:53:04 +0200
commit66bb24cffa127f106bb79e25e60aacb61fe63352 (patch)
treef448ef1ac66c1bc7427f9d3366568baf32f716d9
parente5105c1a35907089dd13c0783ee5940106046896 (diff)
downloadmeta-enea-bsp-x86-66bb24cffa127f106bb79e25e60aacb61fe63352.tar.gz
linux-intel: Fix for CVE-2018-16658
Fix for both linux-intel and linux-intel-rt. References: https://github.com/nluedtke/linux_kernel_cves/blob/master/4.14/4.14_security.txt https://nvd.nist.gov/vuln/detail/CVE-2018-16658 Change-Id: Icaa55f0e2167ee5a72b253bae4cb00d5708d66d1 Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.14.bbappend1
-rw-r--r--recipes-kernel/linux/linux-intel/CVE-2018-16658.patch42
-rw-r--r--recipes-kernel/linux/linux-intel_4.14.bbappend7
3 files changed, 49 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.14.bbappend b/recipes-kernel/linux/linux-intel-rt_4.14.bbappend
index 2b8d8d9..b7934cf 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.14.bbappend
+++ b/recipes-kernel/linux/linux-intel-rt_4.14.bbappend
@@ -12,6 +12,7 @@ SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=s
12 file://CVE-2018-13094.patch \ 12 file://CVE-2018-13094.patch \
13 file://CVE-2018-15572.patch \ 13 file://CVE-2018-15572.patch \
14 file://CVE-2018-9363.patch \ 14 file://CVE-2018-9363.patch \
15 file://CVE-2018-16658.patch \
15 " 16 "
16 17
17# Debug tools support 18# Debug tools support
diff --git a/recipes-kernel/linux/linux-intel/CVE-2018-16658.patch b/recipes-kernel/linux/linux-intel/CVE-2018-16658.patch
new file mode 100644
index 0000000..d6dc109
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/CVE-2018-16658.patch
@@ -0,0 +1,42 @@
1From 73b2e7073b51de0b03ebd15c97dd3ad0c3470810 Mon Sep 17 00:00:00 2001
2From: Scott Bauer <scott.bauer@intel.com>
3Date: Thu, 26 Apr 2018 11:51:08 -0600
4Subject: [PATCH] cdrom: Fix info leak/OOB read in cdrom_ioctl_drive_status
5
6commit 8f3fafc9c2f0ece10832c25f7ffcb07c97a32ad4 upstream.
7
8Like d88b6d04: "cdrom: information leak in cdrom_ioctl_media_changed()"
9
10There is another cast from unsigned long to int which causes
11a bounds check to fail with specially crafted input. The value is
12then used as an index in the slot array in cdrom_slot_status().
13
14CVE: CVE-2018-16658
15Upstream-Status: Backport
16
17Signed-off-by: Scott Bauer <scott.bauer@intel.com>
18Signed-off-by: Scott Bauer <sbauer@plzdonthack.me>
19Cc: stable@vger.kernel.org
20Signed-off-by: Jens Axboe <axboe@kernel.dk>
21Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
22Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
23---
24 drivers/cdrom/cdrom.c | 2 +-
25 1 file changed, 1 insertion(+), 1 deletion(-)
26
27diff --git a/drivers/cdrom/cdrom.c b/drivers/cdrom/cdrom.c
28index bfc566d..8cfa10ab 100644
29--- a/drivers/cdrom/cdrom.c
30+++ b/drivers/cdrom/cdrom.c
31@@ -2542,7 +2542,7 @@ static int cdrom_ioctl_drive_status(struct cdrom_device_info *cdi,
32 if (!CDROM_CAN(CDC_SELECT_DISC) ||
33 (arg == CDSL_CURRENT || arg == CDSL_NONE))
34 return cdi->ops->drive_status(cdi, CDSL_CURRENT);
35- if (((int)arg >= cdi->capacity))
36+ if (arg >= cdi->capacity)
37 return -EINVAL;
38 return cdrom_slot_status(cdi, arg);
39 }
40--
411.9.1
42
diff --git a/recipes-kernel/linux/linux-intel_4.14.bbappend b/recipes-kernel/linux/linux-intel_4.14.bbappend
index e91f5c1..36e0307 100644
--- a/recipes-kernel/linux/linux-intel_4.14.bbappend
+++ b/recipes-kernel/linux/linux-intel_4.14.bbappend
@@ -1,8 +1,13 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
3
1require recipes-kernel/linux/linux-deploy-kconfig.inc 4require recipes-kernel/linux/linux-deploy-kconfig.inc
2 5
3SRCREV_metaenea = "8a4b6e91f12d927b3b486892c50a4ad2bcdb29d2" 6SRCREV_metaenea = "8a4b6e91f12d927b3b486892c50a4ad2bcdb29d2"
4KENEABRANCH = "intel-4.14" 7KENEABRANCH = "intel-4.14"
5SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta" 8SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta \
9 file://CVE-2018-16658.patch \
10 "
6 11
7KERNEL_FEATURES_append = " features/x2apic/x2apic.scc" 12KERNEL_FEATURES_append = " features/x2apic/x2apic.scc"
8 13