summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bbappend b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
index f9311e9..67afd97 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bbappend
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
@@ -1 +1,27 @@
1require recipes-kernel/linux/linux-qoriq-common.inc 1require recipes-kernel/linux/linux-qoriq-common.inc
2
3do_configure_prepend() {
4 # copy desired defconfig so we pick it up for the real kernel_do_configure
5 cp ${KERNEL_DEFCONFIG} ${B}/.config
6
7 # add config fragments
8 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
9 if [ -f "${WORKDIR}/${deltacfg}" ]; then
10 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
11 elif [ -f "${S}/arch/powerpc/configs/${deltacfg}" ]; then
12 ${S}/scripts/kconfig/merge_config.sh -m .config \
13 ${S}/arch/powerpc/configs/${deltacfg}
14 fi
15 done
16
17 #add git revision to the local version
18 if [ "${SCMVERSION}" = "y" ]; then
19 # append sdk version if SDK_VERSION is defined
20 sdkversion=''
21 if [ -n "${SDK_VERSION}" ]; then
22 sdkversion="-${SDK_VERSION}"
23 fi
24 head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
25 printf "%s%s%s" $sdkversion +g $head > ${B}/.scmversion
26 fi
27}