summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Borg <martin.borg@enea.com>2016-10-27 11:22:54 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2016-10-27 15:19:54 +0200
commit416b696974560cdc27d9b314639f57e79be33b9f (patch)
treeab90a375b6da230efa1459a603f7709cc1b2d046
parentee00fbf970c7f04aff02f53f2c95bd43d95d9b22 (diff)
downloadmeta-enea-bsp-ppc-416b696974560cdc27d9b314639f57e79be33b9f.tar.gz
Revert "kernel: CVE-2016-4951"
meta-freescale uses a kernel version that includes this fix. Signed-off-by: Martin Borg <martin.borg@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-kernel/linux/files/CVE-2016-4951.patch43
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bbappend5
2 files changed, 0 insertions, 48 deletions
diff --git a/recipes-kernel/linux/files/CVE-2016-4951.patch b/recipes-kernel/linux/files/CVE-2016-4951.patch
deleted file mode 100644
index e4807b3..0000000
--- a/recipes-kernel/linux/files/CVE-2016-4951.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 49956430d3d55b47e4a2d2f5f777d641cae137d6 Mon Sep 17 00:00:00 2001
2From: Richard Alpe <richard.alpe@ericsson.com>
3Date: Mon, 16 May 2016 11:14:54 +0200
4Subject: tipc: check nl sock before parsing nested attributes
5
6[ Upstream commit 45e093ae2830cd1264677d47ff9a95a71f5d9f9c ]
7
8Make sure the socket for which the user is listing publication exists
9before parsing the socket netlink attributes.
10
11Prior to this patch a call without any socket caused a NULL pointer
12dereference in tipc_nl_publ_dump().
13
14Upstream-Status: Backport
15CVE: CVE-2016-4951
16
17Tested-and-reported-by: Baozeng Ding <sploving1@gmail.com>
18Signed-off-by: Richard Alpe <richard.alpe@ericsson.com>
19Acked-by: Jon Maloy <jon.maloy@ericsson.cm>
20Signed-off-by: David S. Miller <davem@davemloft.net>
21Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
22Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
23---
24 net/tipc/socket.c | 3 +++
25 1 file changed, 3 insertions(+)
26
27diff --git a/net/tipc/socket.c b/net/tipc/socket.c
28index 20cc6df..d41d424 100644
29--- a/net/tipc/socket.c
30+++ b/net/tipc/socket.c
31@@ -2804,6 +2804,9 @@ int tipc_nl_publ_dump(struct sk_buff *skb, struct netlink_callback *cb)
32 if (err)
33 return err;
34
35+ if (!attrs[TIPC_NLA_SOCK])
36+ return -EINVAL;
37+
38 err = nla_parse_nested(sock, TIPC_NLA_SOCK_MAX,
39 attrs[TIPC_NLA_SOCK],
40 tipc_nl_sock_policy);
41--
42cgit v0.12
43
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bbappend b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
index 417cb53..f9311e9 100644
--- a/recipes-kernel/linux/linux-qoriq_4.1.bbappend
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bbappend
@@ -1,6 +1 @@
1require recipes-kernel/linux/linux-qoriq-common.inc require recipes-kernel/linux/linux-qoriq-common.inc
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
4
5SRC_URI += "file://CVE-2016-4951.patch \
6 "