summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Calianu <adrian.calianu@enea.com>2016-05-10 08:31:48 +0200
committerAdrian Calianu <adrian.calianu@enea.com>2016-05-10 08:31:48 +0200
commitada8d1aaf15b3a293c434542e3581754fea3d9f1 (patch)
tree25374805511e135843aeb8d6be279574ec8e633a
parent324d71e3ef072d17bd6c03973b1d24150fe471ce (diff)
downloadmeta-enea-bsp-ppc-ada8d1aaf15b3a293c434542e3581754fea3d9f1.tar.gz
Revert "kernel ipc: fix compat msgrcv with negative msgtyp"
The patch was intergrated by Freescale into meta-fsl-ppc into krogoth and krogoth-next branches(commit 324d71e3ef072d17bd6c03973b1d24150fe471ce). This reverts commit 324d71e3ef072d17bd6c03973b1d24150fe471ce.
-rw-r--r--recipes-kernel/linux/files/Trusty-SRU-ipc-fix-compat-msgrcv-with-negative-msgtyp.patch27
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bbappend2
2 files changed, 0 insertions, 29 deletions
diff --git a/recipes-kernel/linux/files/Trusty-SRU-ipc-fix-compat-msgrcv-with-negative-msgtyp.patch b/recipes-kernel/linux/files/Trusty-SRU-ipc-fix-compat-msgrcv-with-negative-msgtyp.patch
deleted file mode 100644
index b90a114..0000000
--- a/recipes-kernel/linux/files/Trusty-SRU-ipc-fix-compat-msgrcv-with-negative-msgtyp.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1BugLink: http://bugs.launchpad.net/bugs/1393355
2
3Compat function takes msgtyp argument as u32 and passes it down to
4do_msgrcv which results in casting to long, thus the sign is lost and we
5get a big positive number instead.
6
7Cast the argument to signed type before passing it down.
8
9Signed-off-by: Mateusz Guzik <mguzik@redhat.com>
10Reported-by: Gabriellla Schmidt <gsc@bruker.de>
11
12Upstream-Status::Backport
13Kernel 3.14
14
15diff --git a/ipc/compat.c b/ipc/compat.c
16index 892f658..d3b3760 100644
17--- a/ipc/compat.c
18+++ b/ipc/compat.c
19@@ -381,7 +381,7 @@ COMPAT_SYSCALL_DEFINE6(ipc, u32, call, int, first, int, second,
20 uptr = compat_ptr(ipck.msgp);
21 fifth = ipck.msgtyp;
22 }
23- return do_msgrcv(first, uptr, second, fifth, third,
24+ return do_msgrcv(first, uptr, second, (s32)fifth, third,
25 compat_do_msg_fill);
26 }
27 case MSGGET:
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bbappend b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
index bd21278..f9311e9 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bbappend
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bbappend
@@ -1,3 +1 @@
1require recipes-kernel/linux/linux-qoriq-common.inc require recipes-kernel/linux/linux-qoriq-common.inc
2SRC_URI += "file://Trusty-SRU-ipc-fix-compat-msgrcv-with-negative-msgtyp.patch \
3 "