summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/grub/grub_2.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/grub/grub_2.02.bb')
-rw-r--r--recipes-bsp/grub/grub_2.02.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-bsp/grub/grub_2.02.bb b/recipes-bsp/grub/grub_2.02.bb
new file mode 100644
index 0000000..3e61f6a
--- /dev/null
+++ b/recipes-bsp/grub/grub_2.02.bb
@@ -0,0 +1,17 @@
1require grub2.inc
2
3RDEPENDS_${PN} += "diffutils freetype"
4
5do_install_append () {
6 install -d ${D}${sysconfdir}/grub.d
7 # Remove build host references...
8 find "${D}" -name modinfo.sh -type f -exec \
9 sed -i \
10 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
11 -e 's|${DEBUG_PREFIX_MAP}||g' \
12 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
13 {} +
14}
15
16INSANE_SKIP_${PN} = "arch"
17INSANE_SKIP_${PN}-dbg = "arch"