summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/grub/_ignore_grub-efi_2.02.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/grub/_ignore_grub-efi_2.02.bbappend')
-rw-r--r--recipes-bsp/grub/_ignore_grub-efi_2.02.bbappend23
1 files changed, 0 insertions, 23 deletions
diff --git a/recipes-bsp/grub/_ignore_grub-efi_2.02.bbappend b/recipes-bsp/grub/_ignore_grub-efi_2.02.bbappend
deleted file mode 100644
index 630cc68..0000000
--- a/recipes-bsp/grub/_ignore_grub-efi_2.02.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
1# because entire grub folder was taken from newer branch(rocko) we are using a separate bbappend
2# just to facilitate the move of changes(keep only this file) when switch to new branch
3#
4# Determine the target arch for the grub modules
5python __anonymous_prepend () {
6 import re
7 target = d.getVar('TARGET_ARCH')
8 if target == "x86_64":
9 grubtarget = 'x86_64'
10 grubimage = "grub-efi-bootx64.efi"
11 elif re.match('i.86', target):
12 grubtarget = 'i386'
13 grubimage = "grub-efi-bootia32.efi"
14 elif re.match('aarch64', target):
15 grubtarget = 'arm64'
16 grubimage = "grub-efi-bootaa64.efi"
17 else:
18 raise bb.parse.SkipPackage("grub-efi is incompatible with target %s" % target)
19 d.setVar("GRUB_TARGET", grubtarget)
20 d.setVar("GRUB_IMAGE", grubimage)
21}
22
23COMPATIBLE_HOST = "aarch64-enea-linux"