summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-ls1_3.12.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-ls1_3.12.bbappend')
-rw-r--r--recipes-kernel/linux/linux-ls1_3.12.bbappend29
1 files changed, 28 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ls1_3.12.bbappend b/recipes-kernel/linux/linux-ls1_3.12.bbappend
index 338b3bf..e8fd2e4 100644
--- a/recipes-kernel/linux/linux-ls1_3.12.bbappend
+++ b/recipes-kernel/linux/linux-ls1_3.12.bbappend
@@ -1,3 +1,5 @@
1require linux-ls1-common.inc
2
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 4
3SRC_URI += "file://ls1021aiot.dts \ 5SRC_URI += "file://ls1021aiot.dts \
@@ -8,5 +10,30 @@ SRC_URI += "file://ls1021aiot.dts \
8ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" 10ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
9 11
10do_configure_prepend() { 12do_configure_prepend() {
11 cp -rf ${WORKDIR}/ls1021aiot.dts ${S}/arch/arm/boot/dts/ls1021aiot.dts 13 cp -rf ${WORKDIR}/ls1021aiot.dts ${S}/arch/arm/boot/dts/ls1021aiot.dts
14}
15
16do_configure_append() {
17 #
18 # Add Enea specific kernel configs
19 #
20
21 #gather full config fragment paths
22 addon_features=""
23 if [ -n "${ENEA_KERNEL_FRAGMENTS}" ]; then
24 for feature in ${ENEA_KERNEL_FRAGMENTS}; do
25 addon_features="${addon_features} ${WORKDIR}/${feature}"
26 done
27 fi
28
29 #in case there is no .config file yet
30 touch ${B}/.config
31
32 if [ -e "${S}/scripts/kconfig/merge_config.sh" ]; then
33 O=${B} ${S}/scripts/kconfig/merge_config.sh -m .config ${addon_features}
34 else
35 bbfatal "No merge_config.sh found in the kernel tree."
36 fi
37
38 oe_runmake KCONFIG_ALLCONFIG=${B}/.config O=${B} alldefconfig
12} 39}