summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README18
-rw-r--r--conf/layer.conf2
2 files changed, 18 insertions, 2 deletions
diff --git a/README b/README
index 9a93c03..608e14f 100644
--- a/README
+++ b/README
@@ -49,15 +49,31 @@ it.
49Assuming the enea-bsp-arm layer exists at the top-level of your 49Assuming the enea-bsp-arm layer exists at the top-level of your
50yocto build tree, you can add it to the build system by adding the 50yocto build tree, you can add it to the build system by adding the
51location of the enea-bsp-arm layer to bblayers.conf, along with any 51location of the enea-bsp-arm layer to bblayers.conf, along with any
52other layers needed. e.g.: 52other layers needed. This is dependent on the Yocto machine you
53need to build for:
53 54
55 -------------------------------------------
56 local.conf
57 MACHINE = "ls1021aiot"
54 58
59 bblayers.conf
55 BBLAYERS ?= " \ 60 BBLAYERS ?= " \
56 /path/to/yocto/meta \ 61 /path/to/yocto/meta \
57 /path/to/yocto/meta-poky \ 62 /path/to/yocto/meta-poky \
58 /path/to/yocto/meta-enea-bsp-common \ 63 /path/to/yocto/meta-enea-bsp-common \
59 /path/to/yocto/meta-freescale \ 64 /path/to/yocto/meta-freescale \
60 " 65 "
66 -------------------------------------------
67 local.conf
68 MACHINE = "cn8304"
69
70 bblayers.conf
71 BBLAYERS ?= " \
72 /path/to/yocto/meta \
73 /path/to/yocto/meta-poky \
74 /path/to/yocto/meta-enea-bsp-common \
75 "
76 -------------------------------------------
61 77
62II. Misc 78II. Misc
63======== 79========
diff --git a/conf/layer.conf b/conf/layer.conf
index 4a40645..2ae610a 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
9BBFILE_COLLECTIONS += "enea-bsp-arm" 9BBFILE_COLLECTIONS += "enea-bsp-arm"
10BBFILE_PATTERN_enea-bsp-arm = "^${LAYERDIR}/" 10BBFILE_PATTERN_enea-bsp-arm = "^${LAYERDIR}/"
11BBFILE_PRIORITY_enea-bsp-arm = "6" 11BBFILE_PRIORITY_enea-bsp-arm = "6"
12LAYERDEPENDS_enea-bsp-arm = "enea-bsp-common freescale-layer" 12LAYERDEPENDS_enea-bsp-arm = "enea-bsp-common"