summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Borg <martin.borg@enea.com>2017-12-19 14:42:27 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2017-12-19 17:11:42 +0100
commitce6db33b3e146d7d850358eadf99ab6b5857a44a (patch)
tree2b7c9748eed406c30b81e68b19c7d54e66d51dbc
parent0e53491620e788e43769235db34307d6e586c331 (diff)
downloadmeta-enea-bsp-arm-ce6db33b3e146d7d850358eadf99ab6b5857a44a.tar.gz
linux-raspberrypi: add debug tools support
Signed-off-by: Martin Borg <martin.borg@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-kernel/linux/linux-raspberrypi_4.9.bbappend10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend b/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
index 41e9c50..cfe3d0b 100644
--- a/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
+++ b/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
@@ -16,6 +16,14 @@ do_configure_prepend() {
16 cp ${B}/.config ${WORKDIR}/defconfig 16 cp ${B}/.config ${WORKDIR}/defconfig
17} 17}
18 18
19SRCREV_metaenea ?= "43e34f5a4b6e0f6e68c64525728412952add9c84" 19SRCREV_metaenea ?= "0992116a2cf5c7023bd96635c53739c920574f18"
20KENEABRANCH = "raspberrypi-4.9" 20KENEABRANCH = "raspberrypi-4.9"
21SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-cache" 21SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-cache"
22
23# Debug tools support
24KERNEL_FEATURES_append = " features/debug/debug_kernel_y.scc"
25KERNEL_FEATURES_append = " features/kgdb/kgdb_y.scc"
26KERNEL_FEATURES_append = " features/lttng/lttng_y.scc"
27KERNEL_FEATURES_append = " features/latencytop/latencytop_y.scc"
28KERNEL_FEATURES_append = " features/perf/perf_y.scc"
29KERNEL_FEATURES_append = " features/systemtap/systemtap_y.scc"