summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDragos Motrea <Dragos.Motrea@enea.com>2018-01-04 10:49:12 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2018-01-08 10:15:16 +0100
commitc60243465f61d8a76069ebba2e756fbee0e117dd (patch)
tree789f6714dfd909d3d0220ca84ad61affbbef6cf1
parent392d5cf13e4a8cd1ac70f56f95b5b598b25b65e1 (diff)
downloadmeta-enea-bsp-arm-c60243465f61d8a76069ebba2e756fbee0e117dd.tar.gz
kernel-devsrc: fix do_install
The kernel-devsrc install task was failing because of wrong overlays directory path from Makefile. Signed-off-by: Dragos Motrea <Dragos.Motrea@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-kernel/linux/linux-raspberrypi/0001-Changed-overlays-directory-path.patch28
-rw-r--r--recipes-kernel/linux/linux-raspberrypi_4.9.bbappend4
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi/0001-Changed-overlays-directory-path.patch b/recipes-kernel/linux/linux-raspberrypi/0001-Changed-overlays-directory-path.patch
new file mode 100644
index 0000000..f3d49af
--- /dev/null
+++ b/recipes-kernel/linux/linux-raspberrypi/0001-Changed-overlays-directory-path.patch
@@ -0,0 +1,28 @@
1From 09862c159c191314b77003ccf99cd4ae0dd6119d Mon Sep 17 00:00:00 2001
2From: Dragos Motrea <Dragos.Motrea@enea.com>
3Date: Fri, 29 Dec 2017 10:51:09 +0100
4Subject: Changed overlays directory path
5
6Modified dts-dirs to point to the existing overlays directory.
7
8Signed-off-by: Dragos Motrea <Dragos.Motrea@enea.com>
9---
10 arch/arm64/boot/dts/broadcom/Makefile | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/arch/arm64/boot/dts/broadcom/Makefile b/arch/arm64/boot/dts/broadcom/Makefile
14index 7aa03be..6349d57 100644
15--- a/arch/arm64/boot/dts/broadcom/Makefile
16+++ b/arch/arm64/boot/dts/broadcom/Makefile
17@@ -9,7 +9,7 @@ dtb-$(CONFIG_ARCH_BCM_IPROC) += ns2-svk.dtb
18 dtb-$(CONFIG_ARCH_VULCAN) += vulcan-eval.dtb
19 dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b.dtb
20
21-dts-dirs += ../overlays
22+dts-dirs += ../../../../arm/boot/dts/overlays
23
24 always := $(dtb-y)
25 subdir-y := $(dts-dirs)
26--
272.7.4
28
diff --git a/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend b/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
index 424aa53..619a263 100644
--- a/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
+++ b/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
@@ -1,5 +1,9 @@
1require recipes-kernel/linux/linux-deploy-kconfig.inc 1require recipes-kernel/linux/linux-deploy-kconfig.inc
2 2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4
5SRC_URI += "file://0001-Changed-overlays-directory-path.patch"
6
3# Inhibits warnings printed during do_kernel_configcheck 7# Inhibits warnings printed during do_kernel_configcheck
4KCONF_AUDIT_LEVEL = "0" 8KCONF_AUDIT_LEVEL = "0"
5 9