summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Mangeac <Adrian.Mangeac@enea.com>2019-06-20 12:06:00 +0200
committerAdrian Dudau <Adrian.Dudau@enea.com>2019-06-20 19:04:59 +0200
commit454b3597a61812218e7721d5af54102472ef308d (patch)
tree70c474ebfce53c10734c36800168b27ec53c129a
parentd8258934dd81860e2707a4521e1bd4d166757449 (diff)
downloadmeta-enea-bsp-arm-454b3597a61812218e7721d5af54102472ef308d.tar.gz
Fix u-boot build
Add pmu firmare binary needed by the u-boot build stage. Change-Id: Ic81e516df0096a0b8ecb25cb110f46e2911f4925 Signed-off-by: Adrian Mangeac <Adrian.Mangeac@enea.com>
-rwxr-xr-xrecipes-bsp/u-boot/files/pmu-firmware.binbin0 -> 129760 bytes
-rw-r--r--recipes-bsp/u-boot/u-boot-%.bbappend18
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/files/pmu-firmware.bin b/recipes-bsp/u-boot/files/pmu-firmware.bin
new file mode 100755
index 0000000..e7efb52
--- /dev/null
+++ b/recipes-bsp/u-boot/files/pmu-firmware.bin
Binary files differ
diff --git a/recipes-bsp/u-boot/u-boot-%.bbappend b/recipes-bsp/u-boot/u-boot-%.bbappend
new file mode 100644
index 0000000..91ec5d0
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-%.bbappend
@@ -0,0 +1,18 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3
4PMU_FIRMWARE_IMAGE = "pmu-firmware.bin"
5
6SRC_URI += " \
7 file://${PMU_FIRMWARE_IMAGE} \
8 "
9
10
11do_deploy_pmu_firmware () {
12 install -D ${WORKDIR}/${PMU_FIRMWARE_IMAGE} ${BASE_WORKDIR}/../../pmutmp/deploy/images/zynqmp-pmu/pmu-firmware-zynqmp-pmu.bin
13 install -D ${WORKDIR}/${PMU_FIRMWARE_IMAGE} ${BASE_WORKDIR}/../../pmutmp/deploy/images/zynqmp-pmu/pmu-fw.bin
14}
15
16addtask deploy_pmu_firmware before do_compile after do_patch
17
18