summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Borg <martin.borg@enea.com>2017-12-15 13:54:58 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2017-12-19 10:43:44 +0100
commit0e53491620e788e43769235db34307d6e586c331 (patch)
tree525d2aa6fe736bdde8537ceb151c700e9b5f5161
parent13c865cfd032aaae9d615c21ae4571894b9b284a (diff)
downloadmeta-enea-bsp-arm-0e53491620e788e43769235db34307d6e586c331.tar.gz
linux-raspberrypi: Enable kernel cache mechanism
Enable kernel cache based configuration of the linux-raspberrypi kernel. Signed-off-by: Martin Borg <martin.borg@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-kernel/linux/linux-raspberrypi_4.9.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend b/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
new file mode 100644
index 0000000..41e9c50
--- /dev/null
+++ b/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
@@ -0,0 +1,21 @@
1require recipes-kernel/linux/linux-deploy-kconfig.inc
2
3# The meta-raspberrypi layer generates the kernel configuration using
4# "yes '' | make oldconfig", so we need to instruct the Yocto kernel
5# mechanism to use KCONFIG_MODE "--alldefconfig" to produce a similar
6# end result.
7KCONFIG_MODE = "--alldefconfig"
8
9# The .config file generated using the kernel cache mechanism will be
10# cleaned up by meta-raspberrypi layer (see do_configure_prepend()
11# in meta-raspberrypi/recipes-kernel/linux/linux-rpi.inc).
12# As a workaround, we copy the kernel cache generated .config file to
13# ${WORKDIR}/defconfig, which will then be used as default configuration
14# by meta-raspberrypi.
15do_configure_prepend() {
16 cp ${B}/.config ${WORKDIR}/defconfig
17}
18
19SRCREV_metaenea ?= "43e34f5a4b6e0f6e68c64525728412952add9c84"
20KENEABRANCH = "raspberrypi-4.9"
21SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-cache"