summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-06-08 14:44:13 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2016-06-09 17:03:18 +0200
commit3a51839799446a014f23eb43e7e5f7ebe18a2f62 (patch)
treecf2ae34ee3520df4a986e91fa6f24815b5f2b217
parent1ba1b7bc02c9e3661eab2165acb156c70334742a (diff)
downloadmeta-enea-bsp-arm-3a51839799446a014f23eb43e7e5f7ebe18a2f62.tar.gz
linux-ls1: Apply kernel configs
Aplpy the same kernel configs as for the qoriq kernel. meta-fsl-arm has a class overwriting the .config file in do_configure_prepend which makes it impossible to make changes to it in a .bbappend. So we are forced to change it in do_configure_append and force another configuration. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-kernel/linux/linux-ls1-common.inc27
-rw-r--r--recipes-kernel/linux/linux-ls1_3.12.bbappend29
2 files changed, 55 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ls1-common.inc b/recipes-kernel/linux/linux-ls1-common.inc
new file mode 100644
index 0000000..fe8a391
--- /dev/null
+++ b/recipes-kernel/linux/linux-ls1-common.inc
@@ -0,0 +1,27 @@
1require recipes-kernel/linux/enea-common.inc
2
3ENEA_KERNEL_FRAGMENTS += "\
4 cfg/localversion.cfg \
5 cfg/with_modules.cfg \
6 cfg/embedded.cfg \
7 cfg/preempt.cfg \
8 cfg/root_nfs.cfg \
9 cfg/devtmpfs.cfg \
10 cfg/bootlogd.cfg \
11 cfg/mtd_tests.cfg \
12 cfg/latencytop.cfg \
13 cfg/ltp.cfg \
14 cfg/fuse.cfg \
15 cfg/dpa.cfg \
16 cfg/kprobes.cfg \
17 cfg/i2c.cfg \
18 cfg/lttng.cfg \
19 cfg/powertop.cfg \
20 cfg/systemtap.cfg \
21 cfg/kgdb.cfg \
22 cfg/gpio.cfg \
23 cfg/cpusets.cfg \
24 cfg/nfsdv3.cfg \
25 cfg/nfsdv4.cfg \
26 cfg/nls_cp437.cfg \
27 "
diff --git a/recipes-kernel/linux/linux-ls1_3.12.bbappend b/recipes-kernel/linux/linux-ls1_3.12.bbappend
index 338b3bf..e8fd2e4 100644
--- a/recipes-kernel/linux/linux-ls1_3.12.bbappend
+++ b/recipes-kernel/linux/linux-ls1_3.12.bbappend
@@ -1,3 +1,5 @@
1require linux-ls1-common.inc
2
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 4
3SRC_URI += "file://ls1021aiot.dts \ 5SRC_URI += "file://ls1021aiot.dts \
@@ -8,5 +10,30 @@ SRC_URI += "file://ls1021aiot.dts \
8ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" 10ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
9 11
10do_configure_prepend() { 12do_configure_prepend() {
11 cp -rf ${WORKDIR}/ls1021aiot.dts ${S}/arch/arm/boot/dts/ls1021aiot.dts 13 cp -rf ${WORKDIR}/ls1021aiot.dts ${S}/arch/arm/boot/dts/ls1021aiot.dts
14}
15
16do_configure_append() {
17 #
18 # Add Enea specific kernel configs
19 #
20
21 #gather full config fragment paths
22 addon_features=""
23 if [ -n "${ENEA_KERNEL_FRAGMENTS}" ]; then
24 for feature in ${ENEA_KERNEL_FRAGMENTS}; do
25 addon_features="${addon_features} ${WORKDIR}/${feature}"
26 done
27 fi
28
29 #in case there is no .config file yet
30 touch ${B}/.config
31
32 if [ -e "${S}/scripts/kconfig/merge_config.sh" ]; then
33 O=${B} ${S}/scripts/kconfig/merge_config.sh -m .config ${addon_features}
34 else
35 bbfatal "No merge_config.sh found in the kernel tree."
36 fi
37
38 oe_runmake KCONFIG_ALLCONFIG=${B}/.config O=${B} alldefconfig
12} 39}