summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMihaela Martinas <Mihaela.Martinas@enea.com>2015-11-20 11:34:23 +0100
committerTudor Florea <tudor.florea@enea.com>2015-11-21 19:27:33 +0100
commit6c0253a88729981d0708294e25818e4f4c3893d9 (patch)
tree5b09ceab8b6c29d7355eddbf81e500ad8393789b
parent3380e86a98999da9a3febc1b3d93494882162216 (diff)
downloadmeta-enea-bsp-arm-6c0253a88729981d0708294e25818e4f4c3893d9.tar.gz
lttng-ust: add support for aarch64 and aarch64_be
Treat aarch64 and aarch64_be architectures the same as "arm". Signed-off-by: Mihaela Martinas <Mihaela.Martinas@enea.com> Signed-off-by: Tudor Florea <tudor.florea@enea.com>
-rw-r--r--recipes-kernel/lttng/lttng-ust/add-aarch64.patch30
-rw-r--r--recipes-kernel/lttng/lttng-ust_2.5.0.bbappend4
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-kernel/lttng/lttng-ust/add-aarch64.patch b/recipes-kernel/lttng/lttng-ust/add-aarch64.patch
new file mode 100644
index 0000000..9112082
--- /dev/null
+++ b/recipes-kernel/lttng/lttng-ust/add-aarch64.patch
@@ -0,0 +1,30 @@
1lttng-ust: add aarch64 recognition
2
3Treat the same as "arm".
4
5Upstream-Status: Pending
6
7Signed-off-by: Joe Slater <joe.slater@windriver.com>
8
9The patch was imported from OpenEmbedded mailing list
10http://lists.openembedded.org/pipermail/openembedded-core/2014-September/097135.html.
11
12Besides recognizing aarch64, it was also necessary to recognize aarch64_be.
13
14Signed-off-by: Adrian Calianu <adrian.calianu@enea.com>
15Signed-off-by: Alexandru.Vaduva <Alexandru.Vaduva@enea.com>
16
17---
18diff --git a/configure.ac b/configure.ac
19index f507883..40a57d8 100644
20--- a/configure.ac
21+++ b/configure.ac
22@@ -194,6 +194,8 @@ changequote([,])dnl
23 s390) NO_UNALIGNED_ACCESS=1 ;;
24 s390x) NO_UNALIGNED_ACCESS=1 ;;
25 arm*) NO_UNALIGNED_ACCESS=1 ;;
26+ aarch64) NO_UNALIGNED_ACCESS=1 ;;
27+ aarch64_be) NO_UNALIGNED_ACCESS=1 ;;
28 mips*) NO_UNALIGNED_ACCESS=1 ;;
29 tile*) NO_UNALIGNED_ACCESS=1 ;;
30 *) AC_MSG_ERROR([unable to detect alignment requirements (unsupported architecture ($host_cpu)?)]) ;;
diff --git a/recipes-kernel/lttng/lttng-ust_2.5.0.bbappend b/recipes-kernel/lttng/lttng-ust_2.5.0.bbappend
new file mode 100644
index 0000000..7c42fd3
--- /dev/null
+++ b/recipes-kernel/lttng/lttng-ust_2.5.0.bbappend
@@ -0,0 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://add-aarch64.patch \
4 "